summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-10 16:12:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-07-10 23:41:02 +0200
commitff7fb4695d7656feb7b793cd897882b7d49342d6 (patch)
tree158b5f114b558bf186580c8539039aeb0a0ae691 /eclass
parentdev-libs/libjcat: Default-enable gpg and pkcs7 USE flags (diff)
downloadgentoo-ff7fb4695d7656feb7b793cd897882b7d49342d6.tar.gz
gentoo-ff7fb4695d7656feb7b793cd897882b7d49342d6.tar.bz2
gentoo-ff7fb4695d7656feb7b793cd897882b7d49342d6.zip
autotools.eclass: rename configure.in to configure.ac on new EAPIs
automake is "eventually" going to fail when it detects configure.in. Don't do this immediately - instead only on new EAPIs to avoid breaking existing ebuilds. We give an eqawarn (which is triggered by e.g. PORTAGE_ELOG_CLASSES="qa" and is opt-in) for maintainers to upstream these where possible, but this isn't always the case for software ehich otherwise works but is unmaintained upstream. Bug: https://bugs.gentoo.org/426262 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass17
1 files changed, 14 insertions, 3 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index b386654c8328..67ae6d8466b4 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -373,10 +373,21 @@ eautoconf() {
die "No configure.{ac,in} present!"
fi
+
if [[ ${WANT_AUTOCONF} != "2.1" && -e configure.in ]] ; then
- eqawarn "This package has a configure.in file which has long been deprecated. Please"
- eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
- eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ case ${EAPI:-0} in
+ 0|1|2|3|4|5|6|7)
+ eqawarn "This package has a configure.in file which has long been deprecated. Please"
+ eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
+ eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ ;;
+ *)
+ # Move configure file to the new location only on newer EAPIs to ensure
+ # checks are done rather than retroactively breaking ebuilds.
+ eqawarn "Moving configure.in to configure.ac (bug #426262)"
+ mv configure.{in,ac} || die
+ ;;
+ esac
fi
# Install config.guess and config.sub which are required by many macros