summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-08-01 04:58:49 -0500
committerMichał Górny <mgorny@gentoo.org>2018-08-15 12:32:56 +0200
commita16511e49693c90e077c8e0f4162faae214980ff (patch)
tree2c91b779d242ce59ef3d6e3805b18bad41c6c292 /games-action/bzflag/bzflag-2.4.12.ebuild
parentgames-action/bzflag: eutils->{desktop,ltprune} (diff)
downloadgentoo-a16511e49693c90e077c8e0f4162faae214980ff.tar.gz
gentoo-a16511e49693c90e077c8e0f4162faae214980ff.tar.bz2
gentoo-a16511e49693c90e077c8e0f4162faae214980ff.zip
games-action/bzflag: use arrays for myconf
Also added ${EPREFIX} to --libdir for prefix support Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'games-action/bzflag/bzflag-2.4.12.ebuild')
-rw-r--r--games-action/bzflag/bzflag-2.4.12.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-action/bzflag/bzflag-2.4.12.ebuild b/games-action/bzflag/bzflag-2.4.12.ebuild
index 08d5a2254786..7fdb07496ab3 100644
--- a/games-action/bzflag/bzflag-2.4.12.ebuild
+++ b/games-action/bzflag/bzflag-2.4.12.ebuild
@@ -39,18 +39,18 @@ src_prepare() {
}
src_configure() {
- local myconf
+ local myconf=(
+ $(use_enable upnp UPnP)
+ )
if use dedicated ; then
ewarn
ewarn "You are building a server-only copy of BZFlag"
ewarn
- myconf="--disable-client --without-SDL"
+ myconf+=( --disable-client --without-SDL )
fi
- econf \
- $(use_enable upnp UPnP) \
- ${myconf}
+ econf "${myconf[@]}"
}
src_install() {