summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/clanbomber/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/clanbomber/files')
-rw-r--r--games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch11
-rw-r--r--games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch31
2 files changed, 42 insertions, 0 deletions
diff --git a/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch b/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch
new file mode 100644
index 000000000000..e3223108c36a
--- /dev/null
+++ b/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch
@@ -0,0 +1,11 @@
+--- configure.ac.old 2012-11-15 09:35:24.682199511 +0100
++++ configure.ac 2012-11-15 09:36:02.367839076 +0100
+@@ -2,7 +2,7 @@
+ AC_PREREQ([2.63])
+ AC_INIT([ClanBomber], [2.1.1], [rsl@members.fsf.org])
+ #AM_INIT_AUTOMAKE([-Wall -Werror foreign])#foreign is for NEWS COPYING ETC
+-AM_INIT_AUTOMAKE([dist-lzma -Wall -Werror])
++AM_INIT_AUTOMAKE([-Wall])
+
+
+ #CXXFLAGS="-O6 -g3"
diff --git a/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch b/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch
new file mode 100644
index 000000000000..34335bc79f9b
--- /dev/null
+++ b/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch
@@ -0,0 +1,31 @@
+--- src/MapEntry.cpp.old 2012-11-15 10:55:40.123259605 +0100
++++ src/MapEntry.cpp 2012-11-15 10:57:35.217379211 +0100
+@@ -50,7 +50,7 @@
+ enabled = true;
+
+ // extract map name
+- map_name = filename.stem();
++ map_name = filename.stem().string();
+
+ // is the file writable?
+ if (access(path / filename, W_OK) == 0) {
+--- src/Map.cpp.old 2012-11-15 10:52:56.884424228 +0100
++++ src/Map.cpp 2012-11-15 10:54:16.334992079 +0100
+@@ -116,7 +116,7 @@
+ for (boost::filesystem::directory_iterator dir_iter(path);
+ dir_iter != end_iter; dir_iter++) {
+ if (dir_iter->path().extension() == ".map") {
+- map_list.push_back(new MapEntry(path, dir_iter->filename()));
++ map_list.push_back(new MapEntry(path, dir_iter->path().filename()));
+ }
+ }
+ }
+@@ -126,7 +126,7 @@
+ for (boost::filesystem::directory_iterator dir_iter(path);
+ dir_iter != end_iter; dir_iter++) {
+ if (dir_iter->path().extension() == ".map") {
+- map_list.push_back(new MapEntry(path, dir_iter->filename()));
++ map_list.push_back(new MapEntry(path, dir_iter->path().filename()));
+ }
+ }
+ }