summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/heretic2-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/heretic2-demo')
-rw-r--r--games-action/heretic2-demo/Manifest1
-rw-r--r--games-action/heretic2-demo/heretic2-demo-1.06a.ebuild58
-rw-r--r--games-action/heretic2-demo/metadata.xml8
3 files changed, 67 insertions, 0 deletions
diff --git a/games-action/heretic2-demo/Manifest b/games-action/heretic2-demo/Manifest
new file mode 100644
index 000000000000..5486ab4435b3
--- /dev/null
+++ b/games-action/heretic2-demo/Manifest
@@ -0,0 +1 @@
+DIST heretic2-demo.run 55065564 SHA256 623e1a277ff8eb47e48a6fa50f32eb1325eba1591cebdea002a32599464b881a SHA512 62aba7b4569b76bf9a01864652da7be8e268ad3cad4eb5b986b7e84adbd88e826799d021b141f9a7a1135520e440de4ce2e57c5be6ceaa85dc08295d5e3ad30e WHIRLPOOL fdde3e8caf5114e37e9db16801e99638a1fbe20b40c6bdf913d57d8e5f4774fa3d84bb44a365bb16ea6fefd1ad88e08c924bedd6ef58a50bc9612193cc4e8220
diff --git a/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild b/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
new file mode 100644
index 000000000000..c41275b5a311
--- /dev/null
+++ b/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker multilib games
+
+DESCRIPTION="Third-person classic magical action-adventure game"
+HOMEPAGE="http://www.lokigames.com/products/heretic2/
+ http://www.hereticii.com/"
+SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="strip"
+QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/heretic2-demo/ref_glx.so"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/*"
+
+src_install() {
+ ABI=x86
+
+ local demo="data/demos/heretic2_demo"
+ local exe="heretic2_demo.x86"
+
+ loki_patch patch.dat data/ || die
+
+ # Remove bad opengl library
+ rm -r "${demo}/gl_drivers/"
+
+ # Change to safe default of 800x600 and option of normal opengl driver
+ sed -i \
+ -e "s:fullscreen \"1\":fullscreen \"1\"\nset vid_mode \"4\":" \
+ -e "s:libGL:/usr/$(get_libdir)/libGL:" \
+ "${demo}"/base/default.cfg || die
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/*
+ doexe "${demo}/${exe}"
+
+ games_make_wrapper ${PN} "./${exe}" "${dir}" "${dir}"
+ newicon "${demo}"/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Heretic 2 (Demo)" ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-action/heretic2-demo/metadata.xml b/games-action/heretic2-demo/metadata.xml
new file mode 100644
index 000000000000..a72ae8ca0315
--- /dev/null
+++ b/games-action/heretic2-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Power up your mana and help Corvus find the cure to a plague of epic dimensions -- and save the worlds of D'sparil before it's too late! A high-powered and mystical three-dimensional environment will enthrall you, with spectacular sound and visual effects, non-stop action and adventure. Prepare to be ensnared in the visual feast that is the worlds of D'sparil. This is the demo version of the commercially-ported game.
+</longdescription>
+</pkgmetadata>