summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:15:53 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:15:53 -0500
commit3c0498e630bf8a43ee55e1ba11f5913975a2d285 (patch)
treec3e5858ebb9d87707805a3509239fb6067285789 /games-action/koth
parentEAPI=5; minor tidying (diff)
downloadgentoo-3c0498e630bf8a43ee55e1ba11f5913975a2d285.tar.gz
gentoo-3c0498e630bf8a43ee55e1ba11f5913975a2d285.tar.bz2
gentoo-3c0498e630bf8a43ee55e1ba11f5913975a2d285.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-action/koth')
-rw-r--r--games-action/koth/koth-0.8.0.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/games-action/koth/koth-0.8.0.ebuild b/games-action/koth/koth-0.8.0.ebuild
index a3a78b6d5531..0bbe48f16ffa 100644
--- a/games-action/koth/koth-0.8.0.ebuild
+++ b/games-action/koth/koth-0.8.0.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+
+EAPI=5
inherit eutils games
DESCRIPTION="Multiplayer, networked game of little tanks with really big weapons"
@@ -17,20 +18,16 @@ DEPEND="media-libs/libggi"
RDEPEND="${DEPEND}"
src_prepare() {
- sed -i 's:-g -O2::' configure \
- || die "sed configure failed"
+ sed -i 's:-g -O2::' configure || die
cd src
epatch "${FILESDIR}"/${P}-gcc-3.4.patch
- sed -i "s:/etc/koth:${GAMES_SYSCONFDIR}:" cfgfile.h \
- || die "sed cfgfile.h failed"
- sed -i 's:(uint16):(uint16_t):' gfx.c gfx.h \
- || die "sed gfx.c gfx.h failed"
+ sed -i "s:/etc/koth:${GAMES_SYSCONFDIR}:" cfgfile.h || die
+ sed -i 's:(uint16):(uint16_t):' gfx.c gfx.h || die
}
-DOCS="AUTHORS ChangeLog NEWS README doc/*.txt"
-
src_install() {
- default
+ DOCS="AUTHORS ChangeLog NEWS README doc/*.txt" \
+ default
insinto "${GAMES_SYSCONFDIR}"
doins src/koth.cfg
prepgamesdirs