summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/openclonk/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/openclonk/files')
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch20
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-paths.patch67
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch25
-rw-r--r--games-action/openclonk/files/openclonk-wrapper-script.sh9
4 files changed, 121 insertions, 0 deletions
diff --git a/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch b/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch
new file mode 100644
index 000000000000..161258604e6b
--- /dev/null
+++ b/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch
@@ -0,0 +1,20 @@
+--- src/graphics/C4SurfaceLoaders.cpp.old 2015-01-02 18:01:35.768676874 +0100
++++ src/graphics/C4SurfaceLoaders.cpp 2015-01-02 18:02:17.705896683 +0100
+@@ -303,7 +303,7 @@
+ // The doc says to give fake end-of-inputs if there is no more data
+ cinfo->src->next_input_byte = &end_of_input;
+ cinfo->src->bytes_in_buffer = 1;
+- return true;
++ return (boolean)true;
+ }
+ static void skip_input_data (j_decompress_ptr cinfo, long num_bytes)
+ {
+@@ -354,7 +354,7 @@
+ blub.term_source = jpeg_noop;
+
+ // a missing image is an error
+- jpeg_read_header(&cinfo, true);
++ jpeg_read_header(&cinfo, (boolean)true);
+
+ // Let libjpeg convert for us
+ cinfo.out_color_space = JCS_RGB;
diff --git a/games-action/openclonk/files/openclonk-5.5.1-paths.patch b/games-action/openclonk/files/openclonk-5.5.1-paths.patch
new file mode 100644
index 000000000000..02776e21ed69
--- /dev/null
+++ b/games-action/openclonk/files/openclonk-5.5.1-paths.patch
@@ -0,0 +1,67 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Feb 6 19:58:45 UTC 2014
+Subject: make paths modifiable
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -35,6 +35,16 @@
+ set(${_var} "${_string}" PARENT_SCOPE)
+ endfunction()
+
++
++############################################################################
++# User selectable paths
++############################################################################
++set(INSTALL_BINDIR "bin/" CACHE PATH "Binary install destination")
++set(INSTALL_GAMES_BINDIR "games/bin" CACHE PATH "Games binary install destination")
++set(INSTALL_DATAROOTDIR "share/" CACHE PATH "Data root install destination")
++set(INSTALL_DATADIR "${INSTALL_DATAROOTDIR}" CACHE PATH "Data install destination")
++
++
+ ############################################################################
+ # User selectable options
+ ############################################################################
+@@ -1170,10 +1180,16 @@
+ # Assemble compiler flags
+ ############################################################################
+ if(UNIX)
++ if(NOT IS_ABSOLUTE "${INSTALL_DATADIR}")
++ set(ABSOLUTE_INSTALL_DATADIR "${CMAKE_INSTALL_PREFIX}/${INSTALL_DATADIR}")
++ else()
++ set(ABSOLUTE_INSTALL_DATADIR "${INSTALL_DATADIR}")
++ endif()
++
+ # Don't put this into CMAKE_CXX_FLAGS because otherwise it is cached,
+ # and when the path is changed both the old and new definition appears
+ # in the list of flags.
+- add_definitions("-DOC_SYSTEM_DATA_DIR=\"${CMAKE_INSTALL_PREFIX}/share/games/openclonk\"")
++ add_definitions("-DOC_SYSTEM_DATA_DIR=\"${ABSOLUTE_INSTALL_DATADIR}/openclonk\"")
+ endif()
+ if(OC_CXX_FLAGS)
+ list(REMOVE_DUPLICATES OC_CXX_FLAGS)
+@@ -1474,20 +1490,20 @@
+ DEPENDS c4group
+ VERBATIM
+ )
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${group} DESTINATION share/games/openclonk)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${group} DESTINATION "${INSTALL_DATADIR}/openclonk")
+ endif()
+ endforeach()
+
+ if (NOT APPLE)
+ add_custom_target(groups DEPENDS ${OC_C4GROUPS})
+ add_dependencies(data groups)
+-
++
+ # Install new files
+- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/openclonk.desktop DESTINATION share/applications)
++ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/openclonk.desktop DESTINATION "${INSTALL_DATAROOTDIR}/applications")
+
+ # Install binaries
+- install(TARGETS openclonk DESTINATION games)
+- install(TARGETS c4group DESTINATION bin)
++ install(TARGETS openclonk DESTINATION "${INSTALL_GAMES_BINDIR}")
++ install(TARGETS c4group DESTINATION "${INSTALL_BINDIR}")
+ else()
+ install(TARGETS openclonk
+ BUNDLE DESTINATION .
diff --git a/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch b/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch
new file mode 100644
index 000000000000..a55943fc3135
--- /dev/null
+++ b/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch
@@ -0,0 +1,25 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Feb 6 19:58:45 UTC 2014
+Subject: use shared tinyxml
+
+--- a/CMakeLists.txt.old.new
++++ b/CMakeLists.txt
+@@ -1292,7 +1292,6 @@
+ CHECK_INCLUDE_FILE_CXX(getopt.h HAVE_GETOPT_H)
+
+ # TinyXML
+-add_subdirectory(thirdparty/tinyxml)
+ target_link_libraries(openclonk tinyxml)
+
+ if(WIN32)
+--- a/src/lib/StdMeshLoaderXml.cpp
++++ b/src/lib/StdMeshLoaderXml.cpp
+@@ -19,7 +19,7 @@
+ #include "C4Include.h"
+ #include "StdMesh.h"
+ #include "StdMeshLoader.h"
+-#include <tinyxml/tinyxml.h>
++#include <tinyxml.h>
+
+ // Helper class to load things from an XML file with error checking
+ class StdMeshLoader::StdMeshXML
diff --git a/games-action/openclonk/files/openclonk-wrapper-script.sh b/games-action/openclonk/files/openclonk-wrapper-script.sh
new file mode 100644
index 000000000000..9f7e64442887
--- /dev/null
+++ b/games-action/openclonk/files/openclonk-wrapper-script.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+# wrapper prevents the game to look for .ocp files in the current dir
+# which can lead to weird behavior and game freeze
+
+[ -d ~/.clonk/openclonk ] || mkdir -p ~/.clonk/openclonk
+
+cd ~/.clonk/openclonk
+
+exec clonk "$@"