summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-03-15 23:57:07 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-03-15 23:57:36 -0400
commitf257eb94993c8b8453594e82e2c801d9a1b06cb6 (patch)
treedc0feca66f610873eaa704c37b065497240dd3a6 /games-action/openclonk
parentdev-games/wfmath: clean old (diff)
downloadgentoo-f257eb94993c8b8453594e82e2c801d9a1b06cb6.tar.gz
gentoo-f257eb94993c8b8453594e82e2c801d9a1b06cb6.tar.bz2
gentoo-f257eb94993c8b8453594e82e2c801d9a1b06cb6.zip
games-action/openclonk: make sure the active compiler can deal with the fancy c++ code (bug #572554)
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-action/openclonk')
-rw-r--r--games-action/openclonk/openclonk-7.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/games-action/openclonk/openclonk-7.0.ebuild b/games-action/openclonk/openclonk-7.0.ebuild
index be62f00e1f8c..dd0d3d826bc8 100644
--- a/games-action/openclonk/openclonk-7.0.ebuild
+++ b/games-action/openclonk/openclonk-7.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils eutils gnome2-utils python-any-r1 fdo-mime games
+inherit cmake-utils eutils gnome2-utils python-any-r1 fdo-mime toolchain-funcs games
MY_P=${PN}-release-${PV}-src
@@ -43,6 +43,7 @@ RDEPEND="
)
dedicated? ( sys-libs/readline:0= )"
DEPEND="${RDEPEND}
+ || ( >=sys-devel/gcc-4.9 >=sys-devel/clang-3.3 )
virtual/pkgconfig
doc? (
${PYTHON_DEPS}
@@ -56,6 +57,14 @@ PATCHES=(
)
S=${WORKDIR}/${P}-src
+pkg_pretend() {
+ if [[ $(tc-getCXX) == *g++* && $(gcc-version) < 4.9 ]] ; then
+ die 'The active compiler needs to be gcc 4.9 (or newer) or clang'
+ else
+ einfo 'The active compiler should be ok'
+ fi
+}
+
pkg_setup() {
games_pkg_setup
use doc && python-any-r1_pkg_setup