summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 23:26:06 +0000
committerSam James <sam@gentoo.org>2021-04-07 01:57:28 +0000
commit66f63f420241bfd08e2a76817d4a5e3a1cd5805c (patch)
treeb45a1fde9e63d3ceaa1f6dda812dce3439d5acfd /games-action/shadowgrounds-survivor-bin
parentx11-misc/xdg-utils: add virtual/awk BDEPEND (diff)
downloadgentoo-66f63f420241bfd08e2a76817d4a5e3a1cd5805c.tar.gz
gentoo-66f63f420241bfd08e2a76817d4a5e3a1cd5805c.tar.bz2
gentoo-66f63f420241bfd08e2a76817d4a5e3a1cd5805c.zip
games-action/shadowgrounds-survivor-bin: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action/shadowgrounds-survivor-bin')
-rw-r--r--games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1-r1.ebuild (renamed from games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1.ebuild)32
1 files changed, 16 insertions, 16 deletions
diff --git a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1.ebuild b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1-r1.ebuild
index 242be142fe41..09beed77b703 100644
--- a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1.ebuild
+++ b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1-r1.ebuild
@@ -1,34 +1,35 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit unpacker eutils games versionator
+EAPI=7
-DIST_PV=$(get_version_component_range 2)
+inherit desktop unpacker wrapper
+
+DIST_PV=$(ver_cut 2-)
DESCRIPTION="human survivors who battle against the ongoing alien onslaught"
HOMEPAGE="http://shadowgroundsgame.com/survivor/"
SRC_URI="survivorUpdate${DIST_PV/p/}.run"
+S="${WORKDIR}"
LICENSE="frozenbyte-eula"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
RESTRICT="fetch strip"
-DEPEND="app-arch/unzip"
-RDEPEND=">=sys-libs/glibc-2.4
+RDEPEND="
>=sys-devel/gcc-4.3.0
+ >=sys-libs/glibc-2.4
!amd64? (
gnome-base/libglade
)
amd64? (
>=gnome-base/libglade-2.6.4-r1[abi_x86_32(-)]
- )"
-
-S=${WORKDIR}
+ )
+"
+BDEPEND="app-arch/unzip"
-d="${GAMES_PREFIX_OPT}/${PN}"
+d="opt/${PN}"
QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
@@ -38,9 +39,9 @@ pkg_nofetch() {
}
src_unpack() {
- # manually run unzip as the initial seek causes it to exit(1)
+ # Manually run unzip as the initial seek causes it to exit(1)
unpack_zip ${A}
- rm lib*/lib{gcc_s,m,rt,selinux}.so.?
+ rm lib*/lib{gcc_s,m,rt,selinux}.so.? || die
}
src_install() {
@@ -51,7 +52,8 @@ src_install() {
bb="survivor-${b}"
exeinto ${d}
newexe ${bb} ${bb}
- games_make_wrapper ${bb} "./${bb}" "${d}"
+
+ make_wrapper ${bb} "./${bb}" "${d}"
make_desktop_entry ${bb} "Shadowgrounds Survivor ${b}" "Shadowgrounds Survivor"
done
@@ -60,6 +62,4 @@ src_install() {
insinto ${d}
doins -r Config data Profiles *.fbz *.glade *-logo.png
-
- prepgamesdirs
}