summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/shootingstar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/shootingstar')
-rw-r--r--games-action/shootingstar/Manifest1
-rw-r--r--games-action/shootingstar/files/1.2.0-gcc34.patch23
-rw-r--r--games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch10
-rw-r--r--games-action/shootingstar/metadata.xml5
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0.ebuild50
5 files changed, 89 insertions, 0 deletions
diff --git a/games-action/shootingstar/Manifest b/games-action/shootingstar/Manifest
new file mode 100644
index 000000000000..d68c179f37f7
--- /dev/null
+++ b/games-action/shootingstar/Manifest
@@ -0,0 +1 @@
+DIST shootingstar-1.2.0.tar.gz 7755911 SHA256 21ed7e557a77a12c1bde5f968c55659667c1b14702f3b0ca5762d10374c6b1d9 SHA512 5bc13a444c925ab834482fad7f055ea02eac471f454a3f0ed80e50c3b0956586b7bfa68db82e3034696fa2e8ce5beaf10fc8b8583508e1c29c276469ef7b2b74 WHIRLPOOL 543e20c6fc7513d0c61262bab2f949d3b8855e8cbf78dc4dd594d641ae10583621ccac4276557e3bc0fc2fc71dfe2cc4362b774e32123a12f882a4edfcdce9af
diff --git a/games-action/shootingstar/files/1.2.0-gcc34.patch b/games-action/shootingstar/files/1.2.0-gcc34.patch
new file mode 100644
index 000000000000..b55997552fc8
--- /dev/null
+++ b/games-action/shootingstar/files/1.2.0-gcc34.patch
@@ -0,0 +1,23 @@
+diff -ur shootingstar-1.2.0/src/engine/cTextureFont.cpp shootingstar-1.2.0.loz/src/engine/cTextureFont.cpp
+--- shootingstar-1.2.0/src/engine/cTextureFont.cpp 2003-07-06 19:31:10.000000000 +0100
++++ shootingstar-1.2.0.loz/src/engine/cTextureFont.cpp 2004-07-26 20:51:16.992768063 +0100
+@@ -31,6 +31,7 @@
+ #include <stdio.h>
+ #include <GL/gl.h>
+ #include <GL/glu.h>
++#include <math.h>
+ #include "cTextureManager.hpp"
+ #include "Debug.hpp"
+ //------------------------------------------------------------------------------
+diff -ur shootingstar-1.2.0/src/game/cOptions.cpp shootingstar-1.2.0.loz/src/game/cOptions.cpp
+--- shootingstar-1.2.0/src/game/cOptions.cpp 2003-12-22 05:09:06.000000000 +0000
++++ shootingstar-1.2.0.loz/src/game/cOptions.cpp 2004-07-26 21:00:25.265284270 +0100
+@@ -201,7 +201,7 @@
+ dbgError () << "Unable to read from options file\n";
+ throw runtime_error ("Unable to load options");
+ }
+- int (keys.keys[i]) = key; // IS THIS SAFE?
++ keys.keys[i] = (SDLKey)key; // IS THIS SAFE?
+
+ fin >> key;
+ keys.buttons[i] = key;
diff --git a/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
new file mode 100644
index 000000000000..179cf09ebda3
--- /dev/null
+++ b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
@@ -0,0 +1,10 @@
+--- src/engine/dbg.cpp.old 2009-06-03 15:15:46.000000000 +0200
++++ src/engine/dbg.cpp 2009-06-03 16:09:19.000000000 +0200
+@@ -28,6 +28,7 @@
+ #include <vector>
+ #include <map>
+ #include <algorithm>
++#include <cstdio>
+
+ /**********************************************************************
+ * Implementation notes
diff --git a/games-action/shootingstar/metadata.xml b/games-action/shootingstar/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/shootingstar/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/shootingstar/shootingstar-1.2.0.ebuild b/games-action/shootingstar/shootingstar-1.2.0.ebuild
new file mode 100644
index 000000000000..31bba01d6374
--- /dev/null
+++ b/games-action/shootingstar/shootingstar-1.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="A topdown shooter"
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Shooting-Star-19754.shtml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ media-libs/sdl-image"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-gcc34.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+ eautoreconf
+}
+
+src_install () {
+ default
+ newicon -s 128 data/textures/body1.png ${PN}.png
+ make_desktop_entry ${PN} "Shooting Star"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}