summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/spacearyarya-kxl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/spacearyarya-kxl/files')
-rw-r--r--games-action/spacearyarya-kxl/files/spacearyarya-kxl-1.0.2-flags.patch11
-rw-r--r--games-action/spacearyarya-kxl/files/spacearyarya-kxl-1.0.2-gentoo-paths.patch74
2 files changed, 85 insertions, 0 deletions
diff --git a/games-action/spacearyarya-kxl/files/spacearyarya-kxl-1.0.2-flags.patch b/games-action/spacearyarya-kxl/files/spacearyarya-kxl-1.0.2-flags.patch
new file mode 100644
index 000000000000..2239858be998
--- /dev/null
+++ b/games-action/spacearyarya-kxl/files/spacearyarya-kxl-1.0.2-flags.patch
@@ -0,0 +1,11 @@
+respect CFLAGS
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -5,5 +5,5 @@ spacearyarya_SOURCES = extern.h \
+ your.c your.h ranking.c ranking.h \
+ boss.c boss.h
+
+-CFLAGS = @X_CFLAGS@ @KXL_CFLAGS@
++AM_CFLAGS = @X_CFLAGS@ @KXL_CFLAGS@
+ LIBS = @X_LIBS@ -lX11 @KXL_LIBS@ -lKXL
diff --git a/games-action/spacearyarya-kxl/files/spacearyarya-kxl-1.0.2-gentoo-paths.patch b/games-action/spacearyarya-kxl/files/spacearyarya-kxl-1.0.2-gentoo-paths.patch
new file mode 100644
index 000000000000..197dae5e926f
--- /dev/null
+++ b/games-action/spacearyarya-kxl/files/spacearyarya-kxl-1.0.2-gentoo-paths.patch
@@ -0,0 +1,74 @@
+--- bmp/Makefile.am
++++ bmp/Makefile.am
+@@ -1,4 +1,4 @@
+-bmpdir = $(prefix)/share/SpaceAryarya/bmp
++bmpdir = $(BMP_PATH)
+ bmp_DATA = my.bmp enemy1.bmp shot.bmp bomb.bmp\
+ enemy2.bmp kage.bmp wall.bmp wall2.bmp eshot.bmp\
+ boss1_b.bmp boss1_do.bmp boss1_f.bmp\
+--- configure.in
++++ configure.in
+@@ -25,17 +25,20 @@
+ BMP_PATH=/usr/local/share/SpaceAryarya/bmp
+ WAV_PATH=/usr/local/share/SpaceAryarya/wav
+ else
+- DATA_PATH=$prefix/share/SpaceAryarya/data
+- BMP_PATH=$prefix/share/SpaceAryarya/bmp
+- WAV_PATH=$prefix/share/SpaceAryarya/wav
++ DATA_PATH=$datadir/SpaceAryarya/data
++ BMP_PATH=$datadir/SpaceAryarya/bmp
++ WAV_PATH=$datadir/SpaceAryarya/wav
++ SCORE_PATH=$localstatedir/SpaceAryarya
+ fi
+ AC_DEFINE_UNQUOTED(DATA_PATH,"$DATA_PATH")
+ AC_DEFINE_UNQUOTED(BMP_PATH,"$BMP_PATH")
+ AC_DEFINE_UNQUOTED(WAV_PATH,"$WAV_PATH")
++AC_DEFINE_UNQUOTED(SCORE_PATH,"$SCORE_PATH")
+ AC_DEFINE_UNQUOTED(TITLE,"$PACKAGE $VERSION")
+ AC_SUBST(DATA_PATH)
+ AC_SUBST(BMP_PATH)
+ AC_SUBST(WAV_PATH)
++AC_SUBST(SCORE_PATH)
+
+ AC_OUTPUT([data/Makefile wav/Makefile bmp/Makefile src/Makefile
+ spacearyarya.spec Makefile])
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -1,6 +1,7 @@
+-datadir = $(prefix)/share/SpaceAryarya/data
++datadir = $(DATA_PATH)
+ data_DATA = stage1.dat stage2.dat
+ EXTRA_DIST = stage1.dat stage2.dat .score
+
+-install:
+- $(INSTALL) -c -m 666 ./.score $(DESTDIR)$(DATA_PATH)
++install-data-local:
++ $(mkinstalldirs) $(DESTDIR)$(SCORE_PATH)
++ $(INSTALL) -m 660 .score $(DESTDIR)$(SCORE_PATH)
+--- src/ranking.c
++++ src/ranking.c
+@@ -36,7 +36,7 @@
+ FILE *fp;
+ Uint16 i;
+
+- if ((fp = fopen(DATA_PATH "/.score", "r"))) {
++ if ((fp = fopen(SCORE_PATH "/.score", "r"))) {
+ fscanf(fp, "%d", &(Root->HiScore));
+ for (i = 0; i < 5; i ++)
+ fscanf(fp, "%d %d %s",
+@@ -65,7 +65,7 @@
+ FILE *fp;
+ Uint16 i;
+
+- if ((fp = fopen(DATA_PATH "/.score", "w"))) {
++ if ((fp = fopen(SCORE_PATH "/.score", "w"))) {
+ fprintf(fp, "%d\n", Root->HiScore);
+ for (i = 0; i < 5; i ++)
+ fprintf(fp, "%d %d %s\n",
+--- wav/Makefile.am
++++ wav/Makefile.am
+@@ -1,3 +1,3 @@
+-wavdir = $(prefix)/share/SpaceAryarya/wav
++wavdir = $(WAV_PATH)
+ wav_DATA = bgm1.wav bomb.wav hit.wav fire.wav die.wav boss.wav
+ EXTRA_DIST = bgm1.wav bomb.wav hit.wav fire.wav die.wav boss.wav