summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-02 23:39:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-02 23:59:32 -0400
commit1c1e14660885f544ae248ec901cd9777278e81be (patch)
tree02cc20842299065471252199e4c10961f3cb7b91 /games-action/teeworlds
parentdev-python/cbor2: Stabilize 5.4.0 x86, #799968 (diff)
downloadgentoo-1c1e14660885f544ae248ec901cd9777278e81be.tar.gz
gentoo-1c1e14660885f544ae248ec901cd9777278e81be.tar.bz2
gentoo-1c1e14660885f544ae248ec901cd9777278e81be.zip
games-action/teeworlds: revert to providing icon
imagemagick can be messy with delegates and would rather not incur additional dependencies just to convert icons. Also add python3_10 given trivial, and remove unneeded xdg inherit. Closes: https://bugs.gentoo.org/799623 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-action/teeworlds')
-rw-r--r--games-action/teeworlds/Manifest1
-rw-r--r--games-action/teeworlds/teeworlds-0.7.5-r1.ebuild17
2 files changed, 9 insertions, 9 deletions
diff --git a/games-action/teeworlds/Manifest b/games-action/teeworlds/Manifest
index d8c49b839a5f..dc7d42a72fc9 100644
--- a/games-action/teeworlds/Manifest
+++ b/games-action/teeworlds/Manifest
@@ -1 +1,2 @@
DIST teeworlds-0.7.5-src.tar.gz 8935505 BLAKE2B 40cf14e4f6d811df29a98cd51adc773021083e3474cc768998923fb6746e65b17c502d80af8e5613716dd3f12cf1e7cf840ec44b19ad8d214bd2cfa71f1871f3 SHA512 f0c55489b99b06e27298ac42adcf31e1130e7eace6f8672836e50c66c27ab0ccce5b8680c7181a2adc59e1f5808564001b5f0bc8ac7ab355ad8db71328ea7a76
+DIST teeworlds.png 3111 BLAKE2B c0b287b50d2155b556a227d4169656c886a47c6641ac15a40ca398ab9d4d0b0d7bf61c93037d4ad6d19ad9e638204975c5913d88928fee7333b6e360578c3692 SHA512 e3dd4754e14b4a6a6bf616b5f74c1f1c1a87b01522c8e5f9e33855f6f13c4ef65b17ef27015f97f303d00faa38b1441a73a7fe19f7be4541dee3f1a4810acb27
diff --git a/games-action/teeworlds/teeworlds-0.7.5-r1.ebuild b/games-action/teeworlds/teeworlds-0.7.5-r1.ebuild
index 6eb673a54626..f3f44810030a 100644
--- a/games-action/teeworlds/teeworlds-0.7.5-r1.ebuild
+++ b/games-action/teeworlds/teeworlds-0.7.5-r1.ebuild
@@ -3,13 +3,15 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
-inherit xdg cmake desktop python-any-r1
+inherit cmake desktop python-any-r1
DESCRIPTION="Online multi-player platform 2D shooter"
HOMEPAGE="https://www.teeworlds.com/"
-SRC_URI="https://github.com/teeworlds/teeworlds/releases/download/${PV}/teeworlds-${PV}-src.tar.gz"
+SRC_URI="
+ https://github.com/teeworlds/teeworlds/releases/download/${PV}/teeworlds-${PV}-src.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
S="${WORKDIR}/${P}-src"
LICENSE="ZLIB"
@@ -31,9 +33,7 @@ RDEPEND="
dev-libs/openssl:0=
sys-libs/zlib"
DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/imagemagick-tools[png]"
+BDEPEND="${PYTHON_DEPS}"
src_configure() {
local mycmakeargs=(
@@ -47,10 +47,9 @@ src_configure() {
src_install() {
cmake_src_install
- convert "other/icons/teeworlds.ico[0]" ${PN}.png || die
- doicon -s 256 ${PN}.png
-
+ doicon "${DISTDIR}"/${PN}.png
domenu other/teeworlds.desktop
+
newinitd "${FILESDIR}"/${PN}-init.d ${PN}
insinto /etc/${PN}