summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 22:12:36 +0000
committerSam James <sam@gentoo.org>2021-04-06 22:47:20 +0000
commita6a0d6fe27366413ee715036d6860f4d6edce5da (patch)
treec585ede86d1e17127f53435edfd4c132fbf77eea /games-action
parentkde-apps/kdenetwork-filesharing: Fix DESCRIPTION (diff)
downloadgentoo-a6a0d6fe27366413ee715036d6860f4d6edce5da.tar.gz
gentoo-a6a0d6fe27366413ee715036d6860f4d6edce5da.tar.bz2
gentoo-a6a0d6fe27366413ee715036d6860f4d6edce5da.zip
games-action/hotline-miami: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/hotline-miami/hotline-miami-1.0.9a_p20140221-r2.ebuild (renamed from games-action/hotline-miami/hotline-miami-1.0.9a_p20140221-r1.ebuild)28
1 files changed, 14 insertions, 14 deletions
diff --git a/games-action/hotline-miami/hotline-miami-1.0.9a_p20140221-r1.ebuild b/games-action/hotline-miami/hotline-miami-1.0.9a_p20140221-r2.ebuild
index fa19d6e68fda..1a6a8e0ef21e 100644
--- a/games-action/hotline-miami/hotline-miami-1.0.9a_p20140221-r1.ebuild
+++ b/games-action/hotline-miami/hotline-miami-1.0.9a_p20140221-r2.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: unbundle Qt5
+EAPI=7
-EAPI=5
-inherit eutils games
+inherit desktop wrapper
DESCRIPTION="High-octane action game overflowing with raw brutality"
HOMEPAGE="http://www.devolverdigital.com/games/view/hotline-miami"
SRC_URI="HotlineMiami_linux_1392944501.tar.gz"
+S="${WORKDIR}"
LICENSE="all-rights-reserved"
SLOT="0"
@@ -16,11 +16,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="bundled-libs +launcher"
RESTRICT="bindist fetch splitdebug"
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-QA_PREBUILT="${MYGAMEDIR#/}/lib/*
+MYGAMEDIR=opt/${PN}
+QA_PREBUILT="
+ ${MYGAMEDIR#/}/lib/*
${MYGAMEDIR#/}/Hotline
- ${MYGAMEDIR#/}/hotline_launcher"
+ ${MYGAMEDIR#/}/hotline_launcher
+"
+# TODO: unbundle Qt5
RDEPEND="
amd64? (
>=x11-libs/libX11-1.6.2[abi_x86_32(-)]
@@ -53,9 +56,8 @@ RDEPEND="
x11-libs/libXrender
x11-libs/libxcb
)
- )"
-
-S=${WORKDIR}
+ )
+"
pkg_nofetch() {
einfo "Please buy & download ${SRC_URI} from:"
@@ -75,12 +77,10 @@ src_install() {
use launcher && doexe lib/libQt5*
use bundled-libs && doexe libCg* libopenal*
- games_make_wrapper ${PN} "./Hotline" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+ make_wrapper ${PN} "./Hotline" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
make_desktop_entry ${PN}
if use launcher ; then
- games_make_wrapper ${PN}-launcher "./hotline_launcher" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+ make_wrapper ${PN}-launcher "./hotline_launcher" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
make_desktop_entry ${PN}-launcher "${PN} (launcher)"
fi
-
- prepgamesdirs
}