summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-05 12:47:01 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-05 13:45:55 -0500
commitbe9278be49527bf9e8fd460e9a95812007aec09e (patch)
tree9d337e4eb72554da9bba34fc765c01ad41616068 /games-action
parentdev-lang/erlang: version bump to 19.0 (fixes bug 586730) (diff)
downloadgentoo-be9278be49527bf9e8fd460e9a95812007aec09e.tar.gz
gentoo-be9278be49527bf9e8fd460e9a95812007aec09e.tar.bz2
gentoo-be9278be49527bf9e8fd460e9a95812007aec09e.zip
games-action/abuse: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
Diffstat (limited to 'games-action')
-rw-r--r--games-action/abuse/abuse-0.8-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-action/abuse/abuse-0.8-r1.ebuild b/games-action/abuse/abuse-0.8-r1.ebuild
new file mode 100644
index 000000000000..0bbaaa90a785
--- /dev/null
+++ b/games-action/abuse/abuse-0.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Port of Abuse by Crack Dot Com"
+HOMEPAGE="http://abuse.zoy.org/"
+SRC_URI="http://abuse.zoy.org/raw-attachment/wiki/download/${P}.tar.gz"
+
+LICENSE="GPL-2 WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.6[sound,opengl,video]
+ media-libs/sdl-mixer
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ # Source-based install
+ default
+
+ doicon doc/${PN}.png
+ make_desktop_entry abuse Abuse
+}
+
+pkg_postinst() {
+ elog "NOTE: If you had previous version of abuse installed"
+ elog "you may need to remove ~/.abuse for the game to work correctly."
+}