summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 23:13:22 +0000
committerSam James <sam@gentoo.org>2021-04-06 23:13:22 +0000
commitd625151a8c820eb008e8dcce85704c235c730e44 (patch)
tree1efdd759af5ba2b52660836d9a72a173ce7e596c /games-action
parentgames-fps/tribes2: games-util/loki_patch is a BDEPEND (diff)
downloadgentoo-d625151a8c820eb008e8dcce85704c235c730e44.tar.gz
gentoo-d625151a8c820eb008e8dcce85704c235c730e44.tar.bz2
gentoo-d625151a8c820eb008e8dcce85704c235c730e44.zip
games-action/descent3-demo: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild b/games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild
index a7347bf10e23..c0be84464d16 100644
--- a/games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild
+++ b/games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild
@@ -1,34 +1,38 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop eutils unpacker xdg
+inherit desktop unpacker wrapper xdg
DESCRIPTION="Indoor/outdoor 3D combat with evil robotic mining spacecraft"
HOMEPAGE="http://www.lokigames.com/products/descent3/"
SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+S="${WORKDIR}"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa pulseaudio"
REQUIRED_USE="?? ( alsa pulseaudio )"
+
RESTRICT="bindist mirror strip"
-DEPEND="games-util/loki_patch"
-RDEPEND="sys-libs/glibc
+RDEPEND="
+ sys-libs/glibc
>=virtual/opengl-7.0-r1[abi_x86_32(-)]
>=x11-libs/libX11-1.6.2[abi_x86_32(-)]
>=x11-libs/libXext-1.3.2[abi_x86_32(-)]
alsa? ( media-libs/alsa-oss[abi_x86_32(-)] )
- pulseaudio? ( media-sound/pulseaudio[abi_x86_32(-)] )"
+ pulseaudio? ( media-sound/pulseaudio[abi_x86_32(-)] )
+"
+BDEPEND="games-util/loki_patch"
-dir="/opt/${PN}"
-QA_PREBUILT="${dir:1}/descent3_demo.x86
- ${dir:1}/netgames/*.d3m"
-
-S="${WORKDIR}"
+dir="opt/${PN}"
+QA_PREBUILT="
+ ${dir}/descent3_demo.x86
+ ${dir}/netgames/*.d3m
+"
src_install() {
local \
@@ -38,8 +42,8 @@ src_install() {
loki_patch patch.dat data/ || die
- insinto "${dir}"
- exeinto "${dir}"
+ insinto ${dir}
+ exeinto ${dir}
doins -r "${demo}"/*
doexe "${demo}/${exe}"
@@ -63,11 +67,9 @@ src_install() {
pkg_postinst() {
xdg_pkg_postinst
- echo
elog "To play the game run:"
elog " descent3-demo"
elog
elog "If the game appears blank, then run it windowed with:"
elog " descent3-demo -w"
- echo
}