summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 22:20:36 +0000
committerSam James <sam@gentoo.org>2021-04-06 22:47:22 +0000
commite287dfd160fa079e50f9adf4a7126eb49ba518ca (patch)
tree06a94ed4e367dc6820c58ef8009cc6e526c7b9ff /games-action
parentgames-arcade/aquaria: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-e287dfd160fa079e50f9adf4a7126eb49ba518ca.tar.gz
gentoo-e287dfd160fa079e50f9adf4a7126eb49ba518ca.tar.bz2
gentoo-e287dfd160fa079e50f9adf4a7126eb49ba518ca.zip
games-action/swordandsworcery: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/swordandsworcery/swordandsworcery-1.02-r1.ebuild (renamed from games-action/swordandsworcery/swordandsworcery-1.02.ebuild)26
1 files changed, 13 insertions, 13 deletions
diff --git a/games-action/swordandsworcery/swordandsworcery-1.02.ebuild b/games-action/swordandsworcery/swordandsworcery-1.02-r1.ebuild
index a35edbe92d2a..ba249b9f5fda 100644
--- a/games-action/swordandsworcery/swordandsworcery-1.02.ebuild
+++ b/games-action/swordandsworcery/swordandsworcery-1.02-r1.ebuild
@@ -1,15 +1,14 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: unbundle liblua-5.1 when available for multilib
-
-EAPI=5
+EAPI=7
-inherit eutils games
+inherit desktop
DESCRIPTION="An exploratory action adventure game with an emphasis on audiovisual style"
HOMEPAGE="http://www.swordandsworcery.com/"
SRC_URI="${PN}_${PV}.tar.gz"
+S="${WORKDIR}"
LICENSE="CAPYBARA-EULA LGPL-3"
SLOT="0"
@@ -17,10 +16,13 @@ KEYWORDS="-* ~amd64 ~x86"
IUSE="bundled-libs"
RESTRICT="bindist fetch splitdebug"
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-QA_PREBUILT="${MYGAMEDIR#/}/bin/*
- ${MYGAMEDIR#/}/lib/*"
+MYGAMEDIR=opt/${PN}
+QA_PREBUILT="
+ ${MYGAMEDIR#/}/bin/*
+ ${MYGAMEDIR#/}/lib/*
+"
+# TODO: unbundle liblua-5.1 when available for multilib
# linked to pulseaudio
RDEPEND="
virtual/opengl
@@ -74,8 +76,6 @@ RDEPEND="
)
)"
-S=${WORKDIR}
-
pkg_nofetch() {
einfo "Please buy & download ${SRC_URI} from:"
einfo " ${HOMEPAGE}"
@@ -98,11 +98,11 @@ src_install() {
insinto "${MYGAMEDIR}"
doins -r bin lib res
- dogamesbin "${T}"/${PN}
+ dobin "${T}"/${PN}
make_desktop_entry ${PN}
- dohtml README.html
+ docinto html
+ dodoc README.html
fperms +x "${MYGAMEDIR}"/bin/${PN}
- prepgamesdirs
}