summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-09-28 16:13:27 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-09-28 16:14:42 +0100
commitf6322880c50fb07410ad57686f3add9b40465333 (patch)
treef020697abf61d36224d46788ba97442200bb3e2d /games-action
parentprofiles: Mask games-action/crimsonland in non-glibc/multilib profiles (diff)
downloadgentoo-f6322880c50fb07410ad57686f3add9b40465333.tar.gz
gentoo-f6322880c50fb07410ad57686f3add9b40465333.tar.bz2
gentoo-f6322880c50fb07410ad57686f3add9b40465333.zip
games-action/crimsonland: New package
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/crimsonland/Manifest2
-rw-r--r--games-action/crimsonland/crimsonland-1.3.5.ebuild48
-rw-r--r--games-action/crimsonland/metadata.xml8
3 files changed, 58 insertions, 0 deletions
diff --git a/games-action/crimsonland/Manifest b/games-action/crimsonland/Manifest
new file mode 100644
index 000000000000..fe90633ed3dd
--- /dev/null
+++ b/games-action/crimsonland/Manifest
@@ -0,0 +1,2 @@
+DIST Crimsonland-Linux-x86-1.3.5.tar 58620320 BLAKE2B c67f132390e1a1b9a1697e877370f91603d558ddba717608a7f3709bb8395fe5017f598dfed82312f670ed510e4bb307df77978769776de184d5ce72d8792a6e SHA512 14faeeeba2326ece9a88b32442f5c65e3aec8c0a6e7a486a034d2684a8a6bb9059a25c574cc6d8cb798733e5ecd1db8ad25b610ec1d1177c4ec6493f02953e06
+DIST crimsonland.png 33312 BLAKE2B 8bcec3baf2eb55ca37d89a7353d720a4bbcbe87bb83854025e35e7ee388315b43291d901d2166dc67446846a53cbca65fe3d920d431b8a87f1979dcfaaa86a11 SHA512 3aa551d4bbc49cfcda039703b837ca533564ae097bacfc72859fe3f1377e952397199cd6daaaf1b406252fd903390f75236b1a1285cb8c41fe3681c6b3738b94
diff --git a/games-action/crimsonland/crimsonland-1.3.5.ebuild b/games-action/crimsonland/crimsonland-1.3.5.ebuild
new file mode 100644
index 000000000000..bd9ae1cf2249
--- /dev/null
+++ b/games-action/crimsonland/crimsonland-1.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg-utils
+
+DESCRIPTION="A top-down shooter with a touch of RPG"
+HOMEPAGE="https://crimsonland.com/"
+SRC_URI="Crimsonland-Linux-x86-${PV}.tar
+ https://dev.gentoo.org/~chewi/distfiles/${PN}.png"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist mirror splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[abi_x86_32,opengl,video]
+ media-libs/openal[abi_x86_32]
+"
+
+S="${WORKDIR}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe ${PN}
+ make_wrapper ${PN} ./${PN} "${DIR}"
+
+ insinto "${DIR}"
+ doins *.pak *.xml
+
+ dodoc README.txt
+
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Crimsonland
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-action/crimsonland/metadata.xml b/games-action/crimsonland/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/crimsonland/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>