summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/berusky
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/berusky')
-rw-r--r--games-arcade/berusky/Manifest3
-rw-r--r--games-arcade/berusky/berusky-1.7.1.ebuild62
-rw-r--r--games-arcade/berusky/files/berusky-1.7.1-gentoo.patch71
-rw-r--r--games-arcade/berusky/metadata.xml16
4 files changed, 152 insertions, 0 deletions
diff --git a/games-arcade/berusky/Manifest b/games-arcade/berusky/Manifest
new file mode 100644
index 000000000000..158f1941be35
--- /dev/null
+++ b/games-arcade/berusky/Manifest
@@ -0,0 +1,3 @@
+DIST berusky-1.7.1.tar.gz 483794 SHA256 8382218ae37669e457fd552bf4690ad3b2b91d8a52701655a457e191d3da4e74 SHA512 0b0c4d736bfd9b0b62accf11d932271e355cbcbf911e35adb0ccd0bb1b45e06c392d60830bddef04a24689ccfcee7302f2653f6357474ccceba4fd66c44d4383 WHIRLPOOL 7fb845b391512218d2d0fb05f56ea7ad6890e33f1b5c3d025417202b455f96bcff93ef05db962864f374bbc39eb9f9941955af161130324823141e7dfc70118a
+DIST berusky-data-1.7.tar.gz 5366663 SHA256 be6d99f40d65341b32b381c004f32885e3dc114b76a95efbc4c5057ea524401e SHA512 1ccae352b8033df0dd8fe6f09b1daa83b0e25a67999d41a0f21019014620825551a4e22827f96bc28ccdf0958df85c9f3cfd2e8f1e83dd7edac5b0479413d438 WHIRLPOOL 492f5707b5675679c5d8dd42d55835c36c31a5dcab6ade5e40a127f1957268a4a1231d9f68b330e09206cc3ff6987369d8e867f201c82b7278beaec1ef3e07d5
+DIST berusky.png 1714 SHA256 47c8a35366b144f86520e9b52eed372a5c8a3b576f69b45f75d65b2f8937a519 SHA512 a8a5f7f8dca8d686bc05239adda10673e937361514b1aea07dc9fe66f2e009ae7c20b75ab63fd4db8ed206026a009d8620af3471bbb966b5e9b576ce89f66e54 WHIRLPOOL 8ddee6fbcec079a5d47070f8a0d7fd153bb895e993b8fe8023aac412cfb441f53d88db27ec40c254a0cd9d6950e1d9e4d281008382238de5b0cdbd564b1edc39
diff --git a/games-arcade/berusky/berusky-1.7.1.ebuild b/games-arcade/berusky/berusky-1.7.1.ebuild
new file mode 100644
index 000000000000..ab7f99aef548
--- /dev/null
+++ b/games-arcade/berusky/berusky-1.7.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DATAFILE=${PN}-data-1.7
+DESCRIPTION="free logic game based on an ancient puzzle named Sokoban"
+HOMEPAGE="http://anakreon.cz/?q=node/1"
+SRC_URI="http://www.anakreon.cz/download/${P}.tar.gz
+ http://www.anakreon.cz/download/${DATAFILE}.tar.gz
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[X,video]
+ media-libs/sdl-image[png]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ mv ../${DATAFILE}/{berusky.ini,GameData,Graphics,Levels} . || die
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
+ src/defines.h berusky.ini \
+ || die
+ sed -i \
+ -e "/AC_INIT/s/configure.in/${PN}, ${PV}/" \
+ configure.in || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r berusky.ini GameData Graphics Levels
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/berusky/files/berusky-1.7.1-gentoo.patch b/games-arcade/berusky/files/berusky-1.7.1-gentoo.patch
new file mode 100644
index 000000000000..f26c233c39e0
--- /dev/null
+++ b/games-arcade/berusky/files/berusky-1.7.1-gentoo.patch
@@ -0,0 +1,71 @@
+--- Makefile.am
++++ Makefile.am
+@@ -5,8 +5,7 @@
+
+ SUBDIRS = po src data
+
+-beruskydocdir = ${prefix}/doc/berusky
+-beruskydoc_DATA = \
++EXTRA_DIST = \
+ README\
+ COPYING\
+ AUTHORS\
+@@ -15,10 +14,6 @@
+ NEWS\
+ TODO
+
+-EXTRA_DIST = $(beruskydoc_DATA)
+-
+-
+-
+ # Copy all the spec files. Of cource, only one is actually used.
+ dist-hook:
+ for specfile in *.spec; do \
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -3,10 +3,3 @@
+ ## Created by Anjuta - will be overwritten
+ ## If you don't want it to overwrite it,
+ ## Please disable it in the Anjuta project configuration
+-
+-berusky_datadir = $(prefix)/@NO_PREFIX_PACKAGE_DATA_DIR@/@PACKAGE@
+-
+-berusky_data_DATA = \
+- berusky.ini
+-
+-EXTRA_DIST = $(berusky_data_DATA)
+--- berusky.ini
++++ berusky.ini
+@@ -1,9 +1,9 @@
+ # Configuration for berusky game
+
+ # Game data location
+-level_data = /usr/share/berusky/Levels
+-game_data = /usr/share/berusky/GameData
+-graphics_data = /usr/share/berusky/Graphics
++level_data = @GENTOO_DATADIR@/Levels
++game_data = @GENTOO_DATADIR@/GameData
++graphics_data = @GENTOO_DATADIR@/Graphics
+
+ # Graphics settings for game and editor
+ # game runs in 640x480
+@@ -17,7 +17,7 @@
+
+ # Game binary & tmp dir
+ # they're used by editor for "run level" command
+-game_binary = /usr/bin/berusky
++game_binary = @GENTOO_BINDIR@/berusky
+ tmp_data = /var/tmp
+
+ # Dir for users levels (it's the default level dir for level editor)
+--- src/defines.h
++++ src/defines.h
+@@ -446,7 +446,7 @@
+ #define INI_USER_DIRECTORY "~/.berusky"
+ #define INI_USER_LEVELS "~/.berusky/User"
+ #define INI_USER_PROFILES "~/.berusky/Profiles"
+-#define INI_FILE_GLOBAL "/var/games/berusky/"INI_FILE_NAME
++#define INI_FILE_GLOBAL "@GENTOO_DATADIR@/"INI_FILE_NAME
+ #define INI_FILE_USER "~/.berusky/"INI_FILE_NAME
+ #define INI_FILE_LOCAL "./"INI_FILE_NAME
+ #elif WINDOWS
diff --git a/games-arcade/berusky/metadata.xml b/games-arcade/berusky/metadata.xml
new file mode 100644
index 000000000000..2dc670913f47
--- /dev/null
+++ b/games-arcade/berusky/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+Berusky is a free logic game, published under GNU Public License and it's based
+on an ancient puzzle named Sokoban.
+
+An old idea of moving boxes in a maze has been expanded with new logic items
+such as explosives, stones, special gates and so on. In addition, up to five
+bugs can cooperate and be controlled by the player.
+
+In order to leave each level (there's about 120 levels in the game) it is
+necessary to own five keys and also to have a free way to the exit.
+</longdescription>
+</pkgmetadata>