summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 00:42:25 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:32:34 +0000
commitd6dfb128d98288dbf9d8b2a1be24cf1acb766e36 (patch)
treefecc2d6c4c283cbcb68cffa52ba7c9d75a4757b4 /games-arcade/betna
parentgames-arcade/bomns: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-d6dfb128d98288dbf9d8b2a1be24cf1acb766e36.tar.gz
gentoo-d6dfb128d98288dbf9d8b2a1be24cf1acb766e36.tar.bz2
gentoo-d6dfb128d98288dbf9d8b2a1be24cf1acb766e36.zip
games-arcade/betna: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/betna')
-rw-r--r--games-arcade/betna/betna-0.9.7-r1.ebuild (renamed from games-arcade/betna/betna-0.9.7.ebuild)26
1 files changed, 17 insertions, 9 deletions
diff --git a/games-arcade/betna/betna-0.9.7.ebuild b/games-arcade/betna/betna-0.9.7-r1.ebuild
index 57c0d775c4da..0aaf65902004 100644
--- a/games-arcade/betna/betna-0.9.7.ebuild
+++ b/games-arcade/betna/betna-0.9.7-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit desktop toolchain-funcs
DESCRIPTION="Defend your volcano from the attacking ants by firing rocks/bullets at them"
HOMEPAGE="http://koti.mbnet.fi/makegho/c/betna/"
@@ -11,15 +12,16 @@ SRC_URI="http://koti.mbnet.fi/makegho/c/betna/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libsdl[video]"
RDEPEND="${DEPEND}"
src_prepare() {
+ default
+
sed -i \
-e '/blobprintf.*char msg/s/char msg/const char msg/' \
- -e "s:images/:${GAMES_DATADIR}/${PN}/:" \
+ -e "s:images/:/var/lib/${PN}/:" \
src/main.cpp || die
sed -i \
@@ -30,17 +32,23 @@ src_prepare() {
Makefile || die
}
+src_configure() {
+ tc-export CXX
+}
+
src_compile() {
emake clean
emake
}
src_install() {
- dogamesbin betna
- insinto "${GAMES_DATADIR}"/${PN}
+ dobin betna
+ dodoc README Q\&A
+
+ insinto /var/lib/${PN}
doins images/*
+
newicon images/target.bmp ${PN}.bmp
+
make_desktop_entry ${PN} Betna /usr/share/pixmaps/${PN}.bmp
- dodoc README Q\&A
- prepgamesdirs
}