summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/blockrage/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/blockrage/files')
-rw-r--r--games-arcade/blockrage/files/blockrage-0.2.3-config.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-arcade/blockrage/files/blockrage-0.2.3-config.patch b/games-arcade/blockrage/files/blockrage-0.2.3-config.patch
new file mode 100644
index 000000000000..dc1875fc28e8
--- /dev/null
+++ b/games-arcade/blockrage/files/blockrage-0.2.3-config.patch
@@ -0,0 +1,30 @@
+--- configure
++++ configure
+@@ -40,7 +40,7 @@
+ SOUND_OPT=
+
+ MYCC=gcc
+-MYCFLAGS='-s -O2 -Wall `sdl-config --cflags`'" $SOUND_OPT -DSYSCONFDIR=\\\"\${sysconfdir}/\${progname}\\\""
++MYCFLAGS='-Wall `sdl-config --cflags`'" $SOUND_OPT -DSYSCONFDIR=\\\"\${sysconfdir}/\${progname}\\\""
+
+ if test -z "$CC" ; then
+ CC="$MYCC";
+@@ -75,7 +75,6 @@
+ --build=*) build_alias="$cfg_optarg";;
+ --host=*) if test ."$build_alias" != ."$cfg_optarg" ; then
+ printf "configure: cross-compiling not supported\n" >&2
+- exit 1
+ fi;;
+
+ --bindir=*) bindir="$cfg_optarg";;
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -1,7 +1,7 @@
+ OBJS = main.o gfxout.o gfxlib.o menus.o keyboard.o bg.o sound.o global.o timer.o
+
+ $(progname)$(XSUF): $(OBJS)
+- gcc -s -o $(progname)$(XSUF) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) -o $(progname)$(XSUF) $(OBJS) $(LIBS) $(LDFLAGS)
+
+ bg.o: bg.c bg.h global.h main.h
+ gfxlib.o: gfxlib.c gfxlib.h global.h gfxout.h