summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 00:37:23 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:32:33 +0000
commit880b7e4e0c805a1c60899a81c449453a30519b98 (patch)
tree824367a6e2ea108d442145216a1e5e3d921d5f0e /games-arcade/bomns
parentgames-puzzle/seatris: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-880b7e4e0c805a1c60899a81c449453a30519b98.tar.gz
gentoo-880b7e4e0c805a1c60899a81c449453a30519b98.tar.bz2
gentoo-880b7e4e0c805a1c60899a81c449453a30519b98.zip
games-arcade/bomns: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/bomns')
-rw-r--r--games-arcade/bomns/bomns-0.99.2-r1.ebuild (renamed from games-arcade/bomns/bomns-0.99.2.ebuild)35
-rw-r--r--games-arcade/bomns/files/bomns-0.99.2-fpe.patch4
2 files changed, 23 insertions, 16 deletions
diff --git a/games-arcade/bomns/bomns-0.99.2.ebuild b/games-arcade/bomns/bomns-0.99.2-r1.ebuild
index 37632fd1375c..bd574f113189 100644
--- a/games-arcade/bomns/bomns-0.99.2.ebuild
+++ b/games-arcade/bomns/bomns-0.99.2-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools flag-o-matic games
+EAPI=7
+
+inherit autotools flag-o-matic
DESCRIPTION="A fast-paced multiplayer deathmatch arcade game"
HOMEPAGE="http://greenridge.sourceforge.net"
@@ -13,36 +14,42 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gtk editor"
-DEPEND="media-libs/libsdl[video]
+DEPEND="
+ media-libs/libsdl[video]
media-libs/sdl-mixer
- gtk? ( x11-libs/gtk+:2 )"
-RDEPEND=${DEPEND}
+ gtk? ( x11-libs/gtk+:2 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fpe.patch
+)
src_prepare() {
+ default
+
sed -i \
-e "/appicondir/s:\$(prefix):/usr:" \
-e "/desktopdir/s:\$(prefix):/usr:" \
$(find icons -name Makefile.am) \
Makefile.am || die
+
sed -i \
- -e "s:\$*[({]prefix[})]/share:${GAMES_DATADIR}:" \
+ -e "s:\$*[({]prefix[})]/share:/var/lib/:" \
configure.in \
graphics/Makefile.am \
levels/Makefile.am \
sounds/Makefile.am || die
- epatch "${FILESDIR}"/${P}-fpe.patch
+
+ mv configure.{in,ac} || die
+
eautoreconf
}
src_configure() {
filter-flags -fforce-addr
- egamesconf \
+ econf \
--disable-launcher1 \
$(use_enable gtk launcher2) \
$(use_enable editor)
}
-
-src_install() {
- default
- prepgamesdirs
-}
diff --git a/games-arcade/bomns/files/bomns-0.99.2-fpe.patch b/games-arcade/bomns/files/bomns-0.99.2-fpe.patch
index 3a9e39c241af..273212a4f6e1 100644
--- a/games-arcade/bomns/files/bomns-0.99.2-fpe.patch
+++ b/games-arcade/bomns/files/bomns-0.99.2-fpe.patch
@@ -1,5 +1,5 @@
---- src/bomns.cpp.old 2015-01-03 18:44:59.947689613 +0100
-+++ src/bomns.cpp 2015-01-03 18:47:29.854777276 +0100
+--- a/src/bomns.cpp
++++ b/src/bomns.cpp
@@ -432,7 +432,10 @@
if(g_bShowFps)
{