summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-10-18 15:05:50 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-18 15:06:03 +0100
commit5d8bf83756a2536d0b445f49066de3708fa93fee (patch)
tree7b0623f04741667e4e5528d317e0804542c0493d /games-arcade/cavezofphear
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.240,4.9.240,4.14.2... (diff)
downloadgentoo-5d8bf83756a2536d0b445f49066de3708fa93fee.tar.gz
gentoo-5d8bf83756a2536d0b445f49066de3708fa93fee.tar.bz2
gentoo-5d8bf83756a2536d0b445f49066de3708fa93fee.zip
games-arcade/cavezofphear: tweak for -fno-common
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/706880 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-arcade/cavezofphear')
-rw-r--r--games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild3
-rw-r--r--games-arcade/cavezofphear/files/cavezofphear-0.5.1-no-common.patch23
2 files changed, 25 insertions, 1 deletions
diff --git a/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild b/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
index 459bd6d3f2ae..1069f5a9ce3c 100644
--- a/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
+++ b/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,7 @@ S=${WORKDIR}/${P/cavezof/}
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-no-common.patch
sed -i \
-e "s:get_data_dir(.):\"${GAMES_DATADIR}/${PN}/\":" \
src/{chk.c,main.c,gplot.c} \
diff --git a/games-arcade/cavezofphear/files/cavezofphear-0.5.1-no-common.patch b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-no-common.patch
new file mode 100644
index 000000000000..4cc9bb5be02c
--- /dev/null
+++ b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-no-common.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/706880
+--- a/src/editor.c
++++ b/src/editor.c
+@@ -24,7 +24,7 @@
+ #include "common.h"
+ #include "proto.h"
+
+-char map[MAP_YSIZE][MAP_XSIZE];
++extern char map[MAP_YSIZE][MAP_XSIZE];
+ int lock;
+ int last_obj;
+
+--- a/src/frame.c
++++ b/src/frame.c
+@@ -26,7 +26,7 @@ void bail(char *message);
+ void sigint_handler();
+ void sigwinch_handler();
+
+-int need_refresh;
++extern int need_refresh;
+
+ void curses_start(void)
+ {