summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/commandergenius/commandergenius-1.8.0.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/commandergenius/commandergenius-1.8.0.0.ebuild')
-rw-r--r--games-arcade/commandergenius/commandergenius-1.8.0.0.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/games-arcade/commandergenius/commandergenius-1.8.0.0.ebuild b/games-arcade/commandergenius/commandergenius-1.8.0.0.ebuild
new file mode 100644
index 000000000000..2e3466b7c7b1
--- /dev/null
+++ b/games-arcade/commandergenius/commandergenius-1.8.0.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils eutils games
+
+MY_P=CGenius-${PV}-Release-Source
+DESCRIPTION="Open Source Commander Keen clone (needs original game files)"
+HOMEPAGE="http://clonekeenplus.sourceforge.net"
+SRC_URI="mirror://sourceforge/clonekeenplus/CGenius/V${PV:0:3}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="opengl tremor"
+RESTRICT="mirror" # contains keen files, but we do not install them
+
+RDEPEND="media-libs/libsdl2[X,opengl?,sound,video]
+ media-libs/sdl2-image
+ opengl? ( virtual/opengl )
+ tremor? ( media-libs/tremor )
+ !tremor? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig"
+
+S=${WORKDIR}/CGenius-${PV}-Release-Source
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch
+
+ rm -rf vfsroot || die
+
+ cat <<-EOF > version.h
+ #ifndef __CG__VERSION_H__
+ #define __CG__VERSION_H__
+
+ #define CGVERSION "${PV}-Release"
+
+ #endif
+ EOF
+
+ sed -i \
+ -e '/INCLUDE(package.cmake)/d' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAPPDIR="${GAMES_BINDIR}"
+ -DSHAREDIR="/usr/share"
+ -DGAMES_SHAREDIR="${GAMES_DATADIR}"
+ -DDOCDIR="/usr/share/doc/${PF}"
+ -DBUILD_TARGET="LINUX"
+ $(cmake-utils_use opengl OPENGL)
+ $(cmake-utils_use tremor TREMOR)
+ $(cmake-utils_use !tremor OGG)
+ -DUSE_SDL2=1
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon CGLogo.png ${PN}.png
+ newgamesbin "${FILESDIR}"/commandergenius-wrapper commandergenius
+ if [[ -e "${ED}${GAMES_BINDIR}"/CGeniusExe ]] ; then
+ mv "${ED}${GAMES_BINDIR}"/CGeniusExe \
+ "${ED}${GAMES_BINDIR}"/CommanderGenius || die
+ fi
+
+ make_desktop_entry commandergenius
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Check your settings in ~/.CommanderGenius/cgenius.cfg"
+ elog "after you have started the game for the first time."
+ use opengl && elog "You may also want to set \"OpenGL = true\""
+ elog
+ elog "Run the game via:"
+ elog " 'commandergenius [path-to-keen-data]'"
+ elog "or add your keen data dir to the search paths in cgenius.cfg"
+}