summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 00:35:27 +0000
committerSam James <sam@gentoo.org>2021-04-07 01:57:38 +0000
commitb37e88acde2bc04a4d132d0ead74ff7c511260b1 (patch)
tree581d8399f392a6ef0610f0b3e1633baa6d94d1d5 /games-arcade/epiar/epiar-0.5.1.ebuild
parentgames-arcade/epiar: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.tar.gz
gentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.tar.bz2
gentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.zip
games-arcade/epiar: add 0.5.1
Includes patches to: * Unbundle Lua 5.1 * Fix Bashisms Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/epiar/epiar-0.5.1.ebuild')
-rw-r--r--games-arcade/epiar/epiar-0.5.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-arcade/epiar/epiar-0.5.1.ebuild b/games-arcade/epiar/epiar-0.5.1.ebuild
new file mode 100644
index 000000000000..0d640921c5d5
--- /dev/null
+++ b/games-arcade/epiar/epiar-0.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+inherit autotools lua-single
+
+DESCRIPTION="A space adventure/combat game"
+HOMEPAGE="https://epiar.net/"
+SRC_URI="https://github.com/cthielen/Epiar/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ dev-games/physfs
+ dev-libs/libxml2
+ media-libs/ftgl
+ media-libs/libsdl[video]
+ media-libs/sdl-image[png]
+ ${LUA_DEPS}
+"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libX11
+ virtual/opengl
+"
+BDEPEND="
+ app-arch/unzip
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.1-unbundle-lua5.1.patch
+ "${FILESDIR}"/${PN}-0.5.1-fix-bashisms.patch
+)
+
+src_prepare() {
+ default
+
+ # Remove bundled Lua 5.1
+ rm -rf source/lua || die
+
+ eautoreconf
+}