summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-08-31 10:11:52 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-31 10:11:52 +0200
commit9f145ea15cb30f7ce44772895cc03da3aa0c089b (patch)
treeb96a8aff1a59a61e97ebf04c58f92994fbea849e /games-arcade/fishsupper
parentdev-python/alembic: Bump to 1.7.1 (diff)
downloadgentoo-9f145ea15cb30f7ce44772895cc03da3aa0c089b.tar.gz
gentoo-9f145ea15cb30f7ce44772895cc03da3aa0c089b.tar.bz2
gentoo-9f145ea15cb30f7ce44772895cc03da3aa0c089b.zip
games-arcade/fishsupper: fix build, bump EAPI
Closes: https://github.com/gentoo/gentoo/pull/22160 Closes: https://bugs.gentoo.org/739090 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade/fishsupper')
-rw-r--r--games-arcade/fishsupper/files/fishsupper-0.1.6-int16.patch14
-rw-r--r--games-arcade/fishsupper/fishsupper-0.1.6-r3.ebuild (renamed from games-arcade/fishsupper/fishsupper-0.1.6-r2.ebuild)3
2 files changed, 16 insertions, 1 deletions
diff --git a/games-arcade/fishsupper/files/fishsupper-0.1.6-int16.patch b/games-arcade/fishsupper/files/fishsupper-0.1.6-int16.patch
new file mode 100644
index 000000000000..3e4f6edbf631
--- /dev/null
+++ b/games-arcade/fishsupper/files/fishsupper-0.1.6-int16.patch
@@ -0,0 +1,14 @@
+Fix build with clang
+https://bugs.gentoo.org/739090
+
+--- a/src/SFont_gl.cpp
++++ b/src/SFont_gl.cpp
+@@ -223,7 +223,7 @@ void Mafferyew::SFont_gl::create_font_char(SDL_Surface* image,
+ 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000);
+ #endif
+
+- SDL_Rect src_rect = { begin_x, 1, font_char_w, font_height };
++ SDL_Rect src_rect = { (Sint16)begin_x, 1, (Uint16)font_char_w, (Uint16)font_height };
+ SDL_BlitSurface(image, &src_rect, converted, 0);
+
+ GLuint texture;
diff --git a/games-arcade/fishsupper/fishsupper-0.1.6-r2.ebuild b/games-arcade/fishsupper/fishsupper-0.1.6-r3.ebuild
index 1ffdfa94712f..09a8ec5b5f2a 100644
--- a/games-arcade/fishsupper/fishsupper-0.1.6-r2.ebuild
+++ b/games-arcade/fishsupper/fishsupper-0.1.6-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools desktop
@@ -27,6 +27,7 @@ PATCHES=(
"${FILESDIR}"/${P}-ovflfix.patch
"${FILESDIR}"/${P}-asneeded.patch
"${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-int16.patch
)
src_prepare() {