summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-16 21:56:39 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-16 22:26:29 +0200
commit40ec599a87f53eea35202fd853851afe5fca183b (patch)
treec7d1a4afe684302b1e22dbfc2b13e7a2e0e45311 /games-arcade/funnyboat
parentgames-arcade/frozen-bubble: Drop old (diff)
downloadgentoo-40ec599a87f53eea35202fd853851afe5fca183b.tar.gz
gentoo-40ec599a87f53eea35202fd853851afe5fca183b.tar.bz2
gentoo-40ec599a87f53eea35202fd853851afe5fca183b.zip
games-arcade/funnyboat: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade/funnyboat')
-rw-r--r--games-arcade/funnyboat/funnyboat-1.5-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-arcade/funnyboat/funnyboat-1.5-r2.ebuild b/games-arcade/funnyboat/funnyboat-1.5-r2.ebuild
new file mode 100644
index 000000000000..64866dc95d95
--- /dev/null
+++ b/games-arcade/funnyboat/funnyboat-1.5-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils python-single-r1
+
+DESCRIPTION="A side scrolling shooter game starring a steamboat on the sea"
+HOMEPAGE="http://funnyboat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/pygame-1.6.2[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r data *.py
+ python_optimize "${ED%/}"/usr/share/${PN}
+
+ dodoc *.txt
+
+ make_wrapper ${PN} "${EPYTHON} main.py" /usr/share/${PN}
+
+ newicon -s 32 data/kuvake.png ${PN}.png
+ make_desktop_entry ${PN} "Trip on the Funny Boat"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}