summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:33:05 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:09:50 +0100
commitb2a4adbd9ee3bee58b954e298535eeb96c43c88b (patch)
tree331c5dceaddfc03e9ccc5e5f813976d30d1ef02e /games-arcade/methane
parentgames-action/wordwarvi: respect ${PKG_CONFIG} (diff)
downloadgentoo-b2a4adbd9ee3bee58b954e298535eeb96c43c88b.tar.gz
gentoo-b2a4adbd9ee3bee58b954e298535eeb96c43c88b.tar.bz2
gentoo-b2a4adbd9ee3bee58b954e298535eeb96c43c88b.zip
games-arcade/methane: respect ${PKG_CONFIG}
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/methane')
-rw-r--r--games-arcade/methane/files/methane-1.5.1-gentoo.patch16
-rw-r--r--games-arcade/methane/methane-1.5.1-r1.ebuild28
2 files changed, 24 insertions, 20 deletions
diff --git a/games-arcade/methane/files/methane-1.5.1-gentoo.patch b/games-arcade/methane/files/methane-1.5.1-gentoo.patch
index 6d72a2ca7ed5..26a1b438c8a8 100644
--- a/games-arcade/methane/files/methane-1.5.1-gentoo.patch
+++ b/games-arcade/methane/files/methane-1.5.1-gentoo.patch
@@ -1,10 +1,10 @@
---- a/Makefile.old 2012-11-26 18:58:48.201837870 +0100
-+++ b/Makefile 2012-11-27 12:30:16.038998128 +0100
+--- a/Makefile
++++ b/Makefile
@@ -1,5 +1,5 @@
-METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.2 clanDisplay-2.2 clanApp-2.2 clanGL-2.2 clanGL1-2.2 clanSWRender-2.2 clanSound-2.2 clanMikMod-2.2`
-METHANE_LIBS = `pkg-config --libs clanCore-2.2 clanDisplay-2.2 clanApp-2.2 clanGL-2.2 clanGL1-2.2 clanSWRender-2.2 clanSound-2.2 clanMikMod-2.2`
-+METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
-+METHANE_LIBS = `pkg-config --libs clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
++METHANE_FLAGS = -DENABLE_SOUND `${PKG_CONFIG} --cflags clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
++METHANE_LIBS = `${PKG_CONFIG} --libs clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
OBJF = build/game.o build/baddie.o build/methane.o build/target.o build/maps.o build/gfxoff.o build/mapdata.o build/objlist.o build/doc.o build/bitdraw.o build/global.o build/suck.o build/power.o build/goodie.o build/bititem.o build/player.o build/weapon.o build/bitgroup.o build/boss.o build/sound.o build/gasobj.o build/misc.o
@@ -25,8 +25,8 @@
+ $(CXX) ${CXXFLAGS} ${METHANE_FLAGS} -c $< -o $@
---- a/sources/methane.cpp.old 2012-11-27 13:49:22.993003266 +0100
-+++ b/sources/methane.cpp 2012-11-27 17:37:23.051913777 +0100
+--- a/sources/methane.cpp
++++ b/sources/methane.cpp
@@ -80,15 +80,15 @@
return 0;
}
@@ -49,8 +49,8 @@
}
// Set the video mode
---- a/sources/target.cpp.old 2012-11-28 21:34:32.666878913 +0100
-+++ b/sources/target.cpp 2012-11-28 21:35:16.371247221 +0100
+--- a/sources/target.cpp
++++ b/sources/target.cpp
@@ -132,7 +132,7 @@
CL_GraphicContext gc = m_pWindow->get_gc();
diff --git a/games-arcade/methane/methane-1.5.1-r1.ebuild b/games-arcade/methane/methane-1.5.1-r1.ebuild
index d26feb258d71..a3f72605a598 100644
--- a/games-arcade/methane/methane-1.5.1-r1.ebuild
+++ b/games-arcade/methane/methane-1.5.1-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop
+
+inherit desktop toolchain-funcs
DESCRIPTION="Port from an old amiga game"
HOMEPAGE="http://methane.sourceforge.net/"
@@ -11,34 +12,37 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="dev-games/clanlib:2.3[opengl,mikmod]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ # From Fedora
+ "${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-fullscreen.patch
+)
src_prepare() {
default
- eapply "${FILESDIR}"/${P}-gentoo.patch
-
- # From Fedora
- eapply "${FILESDIR}"/${P}-gcc5.patch
- eapply "${FILESDIR}"/${P}-fullscreen.patch
-
sed -i \
-e "s:@GENTOO_DATADIR@:/usr/share:" \
sources/target.cpp || die
+ tc-export PKG_CONFIG
+
# fix weird parallel make issue wrt #450422
mkdir build || die
}
src_install() {
dobin methane
+
insinto /usr/share/${PN}
doins resources/*
+
newicon docs/puff.gif ${PN}.gif
make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt