summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/opentyrian/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/opentyrian/files')
-rw-r--r--games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff15
-rw-r--r--games-arcade/opentyrian/files/2.1.20130907-datapath.diff26
-rw-r--r--games-arcade/opentyrian/files/20090702-datapath.diff23
-rw-r--r--games-arcade/opentyrian/files/20091025-cflag-idiocy.diff12
-rw-r--r--games-arcade/opentyrian/files/20091025-datapath.diff26
-rw-r--r--games-arcade/opentyrian/files/20110517-cflag-idiocy.diff15
-rw-r--r--games-arcade/opentyrian/files/20110517-datapath.diff26
7 files changed, 143 insertions, 0 deletions
diff --git a/games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff b/games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff
new file mode 100644
index 000000000000..39ccf1c79f66
--- /dev/null
+++ b/games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff
@@ -0,0 +1,15 @@
+diff -uNr opentyrian-2.1.20130907.ORIG/Makefile opentyrian-2.1.20130907/Makefile
+--- opentyrian-2.1.20130907.ORIG/Makefile 2013-12-08 17:38:06.982842189 +0000
++++ opentyrian-2.1.20130907/Makefile 2013-12-08 17:38:26.843842798 +0000
+@@ -21,11 +21,6 @@
+
+ # FLAGS ####################################################
+
+-ifneq ($(MAKECMDGOALS), release)
+- EXTRA_CFLAGS += -g3 -O0 -Werror
+-else
+- EXTRA_CFLAGS += -g0 -O2 -DNDEBUG
+-endif
+ EXTRA_CFLAGS += -MMD -pedantic -Wall -Wextra -Wno-missing-field-initializers
+ ifeq ($(WITH_NETWORK), true)
+ EXTRA_CFLAGS += -DWITH_NETWORK
diff --git a/games-arcade/opentyrian/files/2.1.20130907-datapath.diff b/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
new file mode 100644
index 000000000000..5b0143ed9a50
--- /dev/null
+++ b/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
@@ -0,0 +1,26 @@
+diff -uNr opentyrian-2.1.20130907.ORIG/Makefile opentyrian-2.1.20130907/Makefile
+--- opentyrian-2.1.20130907.ORIG/Makefile 2013-12-08 17:40:23.470846371 +0000
++++ opentyrian-2.1.20130907/Makefile 2013-12-08 17:40:49.355847165 +0000
+@@ -49,6 +49,10 @@
+ ALL_LDFLAGS += $(LDFLAGS)
+ LDLIBS += $(EXTRA_LDLIBS) $(SDL_LDLIBS)
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all release clean
+diff -uNr opentyrian-2.1.20130907.ORIG/src/file.c opentyrian-2.1.20130907/src/file.c
+--- opentyrian-2.1.20130907.ORIG/src/file.c 2013-12-08 17:40:23.468846371 +0000
++++ opentyrian-2.1.20130907/src/file.c 2013-12-08 17:40:49.355847165 +0000
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;
diff --git a/games-arcade/opentyrian/files/20090702-datapath.diff b/games-arcade/opentyrian/files/20090702-datapath.diff
new file mode 100644
index 000000000000..53ca3e8c789e
--- /dev/null
+++ b/games-arcade/opentyrian/files/20090702-datapath.diff
@@ -0,0 +1,23 @@
+--- opentyrian/Makefile.orig 2009-07-02 23:19:47.000000000 +0100
++++ opentyrian/Makefile 2009-07-02 23:20:27.000000000 +0100
+@@ -54,6 +54,9 @@
+ CFLAGS += -DSVN_REV=\"$(SVN_REV)\"
+ endif
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
+ ####################################################
+
+ all : $(TARGET)
+--- opentyrian/src/error.c.orig 2009-07-02 23:17:00.000000000 +0100
++++ opentyrian/src/error.c 2009-07-02 23:21:01.000000000 +0100
+@@ -33,7 +33,7 @@
+ JE_boolean dont_die = false;
+
+ #ifndef TARGET_MACOSX
+-static const char *tyrian_searchpaths[] = { "data", "tyrian", "tyrian21" };
++static const char *tyrian_searchpaths[] = { DATA_PATH , "data", "tyrian", "tyrian21" };
+ #endif
+
+ JE_longint JE_getFileSize( const char *filename )
diff --git a/games-arcade/opentyrian/files/20091025-cflag-idiocy.diff b/games-arcade/opentyrian/files/20091025-cflag-idiocy.diff
new file mode 100644
index 000000000000..29ed57c2e29d
--- /dev/null
+++ b/games-arcade/opentyrian/files/20091025-cflag-idiocy.diff
@@ -0,0 +1,12 @@
+--- opentyrian/Makefile.orig 2009-10-25 00:52:54.401229746 +0100
++++ opentyrian/Makefile 2009-10-25 00:54:37.642954736 +0100
+@@ -49,9 +49,6 @@
+
+ # FLAGS ####################################################
+
+-NDEBUG_FLAGS := -g0 -O2 -DNDEBUG
+-DEBUG_FLAGS := -g3 -O0 -Werror
+-
+ CFLAGS += --std=c99 -pedantic -Wall -Wextra -Wno-sign-compare -Wno-missing-field-initializers
+ CFLAGS += -I./src -I$(INCLUDEDIR)
+ LDFLAGS += -L$(LIBDIR) -lm
diff --git a/games-arcade/opentyrian/files/20091025-datapath.diff b/games-arcade/opentyrian/files/20091025-datapath.diff
new file mode 100644
index 000000000000..e83447ebf8f5
--- /dev/null
+++ b/games-arcade/opentyrian/files/20091025-datapath.diff
@@ -0,0 +1,26 @@
+diff -uNr opentyrian.ORIG/Makefile opentyrian/Makefile
+--- opentyrian.ORIG/Makefile 2009-10-25 00:45:41.958937396 +0100
++++ opentyrian/Makefile 2009-10-25 00:47:31.759940038 +0100
+@@ -73,6 +73,10 @@
+ CFLAGS += -DHG_REV='"$(HG_REV)"'
+ endif
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all
+diff -uNr opentyrian.ORIG/src/file.c opentyrian/src/file.c
+--- opentyrian.ORIG/src/file.c 2009-10-25 00:45:41.967228200 +0100
++++ opentyrian/src/file.c 2009-10-25 00:50:21.542979700 +0100
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;
diff --git a/games-arcade/opentyrian/files/20110517-cflag-idiocy.diff b/games-arcade/opentyrian/files/20110517-cflag-idiocy.diff
new file mode 100644
index 000000000000..fbc178ad3418
--- /dev/null
+++ b/games-arcade/opentyrian/files/20110517-cflag-idiocy.diff
@@ -0,0 +1,15 @@
+diff -uNr opentyrian.ORIG//Makefile opentyrian/Makefile
+--- opentyrian.ORIG//Makefile 2011-05-17 11:26:17.030004857 +0100
++++ opentyrian/Makefile 2011-05-17 11:28:48.617004931 +0100
+@@ -18,11 +18,6 @@
+
+ # FLAGS ####################################################
+
+-ifneq ($(MAKECMDGOALS), release)
+- EXTRA_CFLAGS += -g3 -O0 -Werror
+-else
+- EXTRA_CFLAGS += -g0 -O2 -DNDEBUG
+-endif
+ EXTRA_CFLAGS += -MMD -pedantic -Wall -Wextra -Wno-missing-field-initializers
+
+ HG_REV := $(shell hg id -ib && touch src/hg_revision.h)
diff --git a/games-arcade/opentyrian/files/20110517-datapath.diff b/games-arcade/opentyrian/files/20110517-datapath.diff
new file mode 100644
index 000000000000..6d7f52cd6bd6
--- /dev/null
+++ b/games-arcade/opentyrian/files/20110517-datapath.diff
@@ -0,0 +1,26 @@
+diff -uNr opentyrian.ORIG//Makefile opentyrian/Makefile
+--- opentyrian.ORIG//Makefile 2011-05-17 11:26:17.030004857 +0100
++++ opentyrian/Makefile 2011-05-17 11:26:52.595004876 +0100
+@@ -39,6 +39,10 @@
+ ALL_LDFLAGS += $(LDFLAGS)
+ LDLIBS += $(EXTRA_LDLIBS) $(SDL_LDLIBS)
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all release clean
+diff -uNr opentyrian.ORIG//src/file.c opentyrian/src/file.c
+--- opentyrian.ORIG//src/file.c 2011-05-17 11:26:17.020004860 +0100
++++ opentyrian/src/file.c 2011-05-17 11:26:52.595004876 +0100
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;