summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2016-04-22 21:07:26 +0200
committerTupone Alfredo <tupone@gentoo.org>2016-04-22 21:07:26 +0200
commit8336778e344e678f3ccca4a444abe3ce398ab491 (patch)
treed95deff7623591e9ec1e30cb07faeec298d9397a /games-arcade/performous
parentapp-misc/ca-certificates: drop duplicate symlink cleanup warning #575124 (diff)
downloadgentoo-8336778e344e678f3ccca4a444abe3ce398ab491.tar.gz
gentoo-8336778e344e678f3ccca4a444abe3ce398ab491.tar.bz2
gentoo-8336778e344e678f3ccca4a444abe3ce398ab491.zip
games-arcade/performous: Fix gcc-5 build. Bug #570572
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-arcade/performous')
-rw-r--r--games-arcade/performous/files/performous-1.0-gcc52.patch11
-rw-r--r--games-arcade/performous/performous-1.0.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/games-arcade/performous/files/performous-1.0-gcc52.patch b/games-arcade/performous/files/performous-1.0-gcc52.patch
new file mode 100644
index 000000000000..dc3eb6b6d125
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-gcc52.patch
@@ -0,0 +1,11 @@
+--- game/songparser.hh.old 2016-04-19 21:57:29.594132735 +0200
++++ game/songparser.hh 2016-04-19 21:57:55.736682808 +0200
+@@ -33,7 +33,7 @@
+ Song& m_song;
+ std::stringstream m_ss;
+ unsigned int m_linenum;
+- bool getline(std::string& line) { ++m_linenum; return std::getline(m_ss, line);}
++ bool getline(std::string& line) { ++m_linenum; return !std::getline(m_ss, line).fail();}
+ bool m_relative;
+ double m_gap;
+ double m_bpm;
diff --git a/games-arcade/performous/performous-1.0.ebuild b/games-arcade/performous/performous-1.0.ebuild
index ab277f8f3996..9fa6cdf80dac 100644
--- a/games-arcade/performous/performous-1.0.ebuild
+++ b/games-arcade/performous/performous-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -61,6 +61,7 @@ src_prepare() {
"${FILESDIR}"/${P}-libav.patch \
"${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-linguas.patch \
+ "${FILESDIR}"/${P}-gcc52.patch \
"${FILESDIR}"/${P}-include.patch
sed -i \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \