summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-21 19:18:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-21 23:31:11 +0100
commit3e2ca41ffacb5f43b59edfcb83e3aaa35d98963d (patch)
tree43b970f64918e5b512cb8c498a0bc5ca1c5749cc /games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
parentapp-admin/ansible: 2.7.8 and 2.6.14 bump (diff)
downloadgentoo-3e2ca41ffacb5f43b59edfcb83e3aaa35d98963d.tar.gz
gentoo-3e2ca41ffacb5f43b59edfcb83e3aaa35d98963d.tar.bz2
gentoo-3e2ca41ffacb5f43b59edfcb83e3aaa35d98963d.zip
games-arcade/slimevolley: EAPI-7 bump, drop insignificant USE
sdl-net is nowhere else optional, it is super small, it does not warrant a patch just to fix a related cmake warning. Closes: https://bugs.gentoo.org/678508 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild')
-rw-r--r--games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild b/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
index e4a8fe67dfab..8b9cc92724b5 100644
--- a/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
+++ b/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit cmake-utils
DESCRIPTION="A simple volleyball game"
@@ -11,20 +12,21 @@ SRC_URI="http://downloads.tuxfamily.org/slime/v242/${PN}_${PV}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="net"
+IUSE=""
-RDEPEND="
+BDEPEND="
+ sys-devel/gettext
+"
+DEPEND="
media-libs/libsdl[X,sound,video]
- media-libs/sdl-ttf
media-libs/sdl-image[png]
- net? ( media-libs/sdl-net )
+ media-libs/sdl-net
+ media-libs/sdl-ttf
virtual/libintl
"
-DEPEND="${RDEPEND}
- sys-devel/gettext
-"
+RDEPEND="${DEPEND}"
-DOCS="docs/README docs/TODO"
+DOCS=( docs/{README,TODO} )
PATCHES=(
"${FILESDIR}"/${P}-nodatalocal.patch
@@ -35,10 +37,9 @@ S="${WORKDIR}/${PN}"
src_configure() {
local mycmakeargs=(
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DCMAKE_INSTALL_PREFIX=/usr"
- "-DDATA_DIR=/usr/share/slimevolley"
- $(use net && echo "-DNO_NET=0" || echo "-DNO_NET=1")
+ -DCMAKE_VERBOSE_MAKEFILE=TRUE
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DDATA_DIR=/usr/share/slimevolley
)
cmake-utils_src_configure
}