summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/snake3d/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/snake3d/files')
-rw-r--r--games-arcade/snake3d/files/snake3d-0.9-amd64.patch37
-rw-r--r--games-arcade/snake3d/files/snake3d-0.9-build.patch24
2 files changed, 61 insertions, 0 deletions
diff --git a/games-arcade/snake3d/files/snake3d-0.9-amd64.patch b/games-arcade/snake3d/files/snake3d-0.9-amd64.patch
new file mode 100644
index 000000000000..d2b5f2c79acd
--- /dev/null
+++ b/games-arcade/snake3d/files/snake3d-0.9-amd64.patch
@@ -0,0 +1,37 @@
+--- src/functions.cpp.old 2007-03-31 11:04:10.000000000 +0200
++++ src/functions.cpp 2007-03-31 11:11:52.000000000 +0200
+@@ -107,8 +107,8 @@
+ pointer = end;
+ }
+
+- memcpy(str, i, (int)pointer - (int)i);
+- str[(int)pointer - (int)i] = 0;
++ memcpy(str, i, ssize_t(pointer - i));
++ str[pointer - i] = 0;
+
+ drawString(x, y, str);
+
+@@ -501,15 +501,21 @@
+
+ Uint32 timer(Uint32 interval, void* value) {
+
++ union {
++ void *value;
++ int p_mode;
++ } p_modeConv;
++ p_modeConv.value = value;
++
+ //if ((int)value != gameModeValue)
+- if ((int)value != p_mode)
++ if (p_modeConv.p_mode != p_mode)
+ return 0;
+
+ SDL_Event event;
+ SDL_UserEvent userevent;
+
+ userevent.type = SDL_USEREVENT;
+- userevent.code = (int)value;
++ userevent.code = p_modeConv.p_mode;
+ userevent.data1 = NULL;
+ userevent.data2 = NULL;
+
diff --git a/games-arcade/snake3d/files/snake3d-0.9-build.patch b/games-arcade/snake3d/files/snake3d-0.9-build.patch
new file mode 100644
index 000000000000..f7d8c4404df4
--- /dev/null
+++ b/games-arcade/snake3d/files/snake3d-0.9-build.patch
@@ -0,0 +1,24 @@
+--- src/Makefile
++++ src/Makefile
+@@ -1,10 +1,10 @@
+ OBJ = board.o snake.o game.o menu.o snake3d.o global.o consts.o cube.o functions.o preferences.o rooms2.o network.o userInput.o server.o packets.o client.o classic2d.o
+-CXXFLAGS = -g -Wall -I/usr/X11R6/include/ `sdl-config --cflags`
++CXXFLAGS += -Wall $(shell sdl-config --cflags)
+ CXX = g++
+ CC = g++
+ #LDFLAGSMAC = -framework GLUT -framework OpenGL -framework Cocoa -bind_at_load -L/sw/lib/ -lSDL -lSDLmain
+ LDFLAGSMAC = `sdl-config --libs` -framework GLUT -framework OpenGL -lSDL_net
+-LDFLAGS = -L/usr/X11R6/lib/ -lGL -lglut -lGLU -lSDL -lSDL_net
++LIBS = -lGL -lglut -lGLU $(shell sdl-config --libs) -lSDL_net
+
+ all: snake3d
+
+@@ -18,7 +18,7 @@
+ g++ $(LDFLAGSMAC) $(OBJ) -o ../snake3d
+
+ snake3d.linux: $(OBJ)
+- g++ $(LDFLAGS) $(OBJ) -o ../snake3d
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJ) $(LIBS) -o ../snake3d
+
+
+ clean: