summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/supertransball2/supertransball2-1.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/supertransball2/supertransball2-1.5.ebuild')
-rw-r--r--games-arcade/supertransball2/supertransball2-1.5.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/games-arcade/supertransball2/supertransball2-1.5.ebuild b/games-arcade/supertransball2/supertransball2-1.5.ebuild
new file mode 100644
index 000000000000..5eba7aa708d7
--- /dev/null
+++ b/games-arcade/supertransball2/supertransball2-1.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator games
+
+MY_PV=$(delete_all_version_separators)
+MY_P=stransball2-v${MY_PV}
+FILE=${MY_P}-linux
+DEBIAN_PATCH="${PN}_${PV}-3.diff"
+
+DESCRIPTION="Thrust clone"
+HOMEPAGE="http://www.braingames.getput.com/stransball2/"
+SRC_URI="http://braingames.bugreport.nl/stransball2/${FILE}.zip
+ mirror://debian/pool/main/s/${PN}/${DEBIAN_PATCH}.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ media-libs/sge"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}/sources
+
+src_unpack() {
+ unpack ${A}
+ mv -f "${FILE}" ${P}
+}
+
+src_prepare() {
+ cd "${WORKDIR}"
+ sed -i \
+ -e "s:/usr/share/games:${GAMES_DATADIR}:" \
+ "${DEBIAN_PATCH}" || die
+
+ epatch "${DEBIAN_PATCH}"
+
+ local deb_dir=${P}/debian/patches
+ rm -f "${deb_dir}"/00list
+ epatch "${deb_dir}"/*
+
+ cd "${S}"
+ sed -i \
+ -e "s: -I/usr/local/include/SDL::" \
+ -e "s:-g3 -O3:\$(CXXFLAGS):" \
+ -e "s:c++:\$(CXX):" \
+ Makefile || die "sed Makefile failed"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_install() {
+ cd ..
+ dogamesbin ${PN}
+ make_desktop_entry ${PN} "Super Transball 2"
+ dodoc readme.txt
+ doman debian/supertransball2.6
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r demos graphics maps sound
+
+ prepgamesdirs
+}