summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-22 23:30:13 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-22 23:30:33 -0500
commita6f2ea090989ec0dd8703c6fdd6a6f88a45bf1a3 (patch)
tree205df0e73c88da8ea1d4497ec3ce16b3684b6167 /games-arcade/supertux/files/supertux-0.4.0-flags.patch
parentsys-cluster/ceph: restore systemd unit files for 0.94.5 (diff)
downloadgentoo-a6f2ea090989ec0dd8703c6fdd6a6f88a45bf1a3.tar.gz
gentoo-a6f2ea090989ec0dd8703c6fdd6a6f88a45bf1a3.tar.bz2
gentoo-a6f2ea090989ec0dd8703c6fdd6a6f88a45bf1a3.zip
version bump (bug #564076)
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-arcade/supertux/files/supertux-0.4.0-flags.patch')
-rw-r--r--games-arcade/supertux/files/supertux-0.4.0-flags.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/supertux/files/supertux-0.4.0-flags.patch b/games-arcade/supertux/files/supertux-0.4.0-flags.patch
new file mode 100644
index 000000000000..97e3e7408ea5
--- /dev/null
+++ b/games-arcade/supertux/files/supertux-0.4.0-flags.patch
@@ -0,0 +1,32 @@
+--- CMakeLists.txt.orig
++++ CMakeLists.txt
+@@ -329,7 +329,7 @@
+ endif(COMPILER_SUPPORTS_CXX11)
+
+
+-IF(CMAKE_COMPILER_IS_GNUCC)
++IF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS)
+ SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g" CACHE STRING "Debug flags")
+ SET(CMAKE_C_FLAGS_DEBUG "-O0 -g" CACHE STRING "Debug flags")
+ SET(CMAKE_CXX_FLAGS_PROFILE "-pg" CACHE STRING "Profile flags")
+@@ -352,7 +352,7 @@
+ # -Wlogical-op -Wstrict-null-sentinel
+ SET(SUPERTUX2_EXTRA_WARNING_FLAGS "-fdiagnostics-show-option -pedantic -Wno-long-long -Wcast-align -Wdisabled-optimization -Winit-self -Winvalid-pch -Wmissing-include-dirs -Wmissing-noreturn -Wpacked -Wredundant-decls -Wstack-protector -Wformat=2 -Weffc++ -Wctor-dtor-privacy -Wno-unused-parameter -Wshadow -Wnon-virtual-dtor -Wcast-qual")
+ ENDIF(WARNINGS)
+-ENDIF(CMAKE_COMPILER_IS_GNUCC)
++ENDIF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS)
+
+ ## If xgettext is available, generate messages.pot for sources
+
+@@ -407,9 +407,9 @@
+ ENDIF(GENERATE_MESSAGESPOT)
+
+ ## Some additional compiler switches
+-IF(CMAKE_COMPILER_IS_GNUCC)
++IF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-strict-aliasing")
+-ENDIF(CMAKE_COMPILER_IS_GNUCC)
++ENDIF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS)
+
+ IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ ADD_DEFINITIONS(-DMACOSX)