summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/vor/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/vor/files')
-rw-r--r--games-arcade/vor/files/vor-0.5.5-underlink.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-arcade/vor/files/vor-0.5.5-underlink.patch b/games-arcade/vor/files/vor-0.5.5-underlink.patch
new file mode 100644
index 000000000000..0645c5695733
--- /dev/null
+++ b/games-arcade/vor/files/vor-0.5.5-underlink.patch
@@ -0,0 +1,26 @@
+--- Makefile.in
++++ Makefile.in
+@@ -43,7 +43,7 @@
+ SDL_CFLAGS := @SDL_CFLAGS@
+ SDL_LIBS := @SDL_LIBS@
+
+-ldflags := $(SDL_LIBS) -lSDL_image -lSDL_mixer $(LDFLAGS)
++ldflags := $(LIBS) $(SDL_LIBS) $(LDFLAGS)
+ cflags := -I. $(SDL_CFLAGS) $(paths) $(CFLAGS)
+
+ my_objects := args.@OBJEXT@ dust.@OBJEXT@ file.@OBJEXT@ mt.@OBJEXT@ rocks.@OBJEXT@ score.@OBJEXT@ sprite.@OBJEXT@ sound.@OBJEXT@ autopilot.@OBJEXT@
+
+--- configure.ac
++++ configure.ac
+@@ -12,6 +12,11 @@
+ AC_PROG_MAKE_SET
+
+ # Checks for libraries.
++dnl Check for libm for sqrt()
++AC_SEARCH_LIBS([sqrt], [m], [], [
++ AC_MSG_ERROR([unable to find the sqrt() function])
++])
++
+ AC_CHECK_LIB([SDL_image], [IMG_LoadPNG_RW])
+ AC_CHECK_LIB([SDL_mixer], [Mix_OpenAudio])
+