summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/wop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/wop')
-rw-r--r--games-arcade/wop/Manifest2
-rw-r--r--games-arcade/wop/files/wop-0.4.3-Makefile.patch54
-rw-r--r--games-arcade/wop/files/wop-0.4.3-gcc43.patch32
-rw-r--r--games-arcade/wop/metadata.xml5
-rw-r--r--games-arcade/wop/wop-0.4.3-r1.ebuild58
5 files changed, 151 insertions, 0 deletions
diff --git a/games-arcade/wop/Manifest b/games-arcade/wop/Manifest
new file mode 100644
index 000000000000..dc9bb7d31fd8
--- /dev/null
+++ b/games-arcade/wop/Manifest
@@ -0,0 +1,2 @@
+DIST wop-0.4.3-src.tar.bz2 280974 SHA256 7e7213e5e5f5af9154c255132ca772c8e6d7815a1a1915fc5faa443c8f40ff23 SHA512 259f9f455e6fbfae2ffb6e169dcf1661f1353e28a5e51b6e907f2868a50c5f54982b4d383dcfcec201c9a2d0429fb468c44c974695364c5fd28d25328e10c6b8 WHIRLPOOL 96c0f518f6b38cbfdc79e681a07cf70f5da2b97733cfd92f9ad8266491e5a841cb8fa59d873e80405c76cc3df75535b60945bb5546851f34d989e54ba18ce7fa
+DIST wopdata-2005-12-21.tar.bz2 4217006 SHA256 cd6b8eb9f77f709d7a52b913d8a665bd202c53ceca9cf96b4c9f9adc17d8a6b2 SHA512 6ebc264d1811091550d664a77aeae68184a058c666db486e4ae411e0849abbd02dd2037a3a1a9a31a73774e5f616c21840b0c1de58636dde0e59bd0e952cb505 WHIRLPOOL cebc7aceea1fb2736d466baf903c373a1444879da58a551b5d553e8b989d50e5a26bc1e71ebb7d289c5c8253a47b004c5461e91f23527db615f627a23be327a9
diff --git a/games-arcade/wop/files/wop-0.4.3-Makefile.patch b/games-arcade/wop/files/wop-0.4.3-Makefile.patch
new file mode 100644
index 000000000000..a7d2e67f9dc6
--- /dev/null
+++ b/games-arcade/wop/files/wop-0.4.3-Makefile.patch
@@ -0,0 +1,54 @@
+--- Makefile.orig 2007-04-23 18:27:32 +0000
++++ Makefile 2007-04-23 18:27:50 +0000
+@@ -3,22 +3,22 @@
+ sinclude Makefile.local
+
+ all:
+- +cd sdlwidgets; make
+- +cd src; make
++ +cd sdlwidgets; $(MAKE)
++ +cd src; $(MAKE)
+ runc:
+- +cd src; make runc
++ +cd src; $(MAKE) runc
+ runs:
+- +cd src; make runs
++ +cd src; $(MAKE) runs
+ doc:
+- cd src; make doc
++ cd src; $(MAKE) doc
+ clean:
+- cd sdlwidgets; make clean
+- cd src; make clean
++ cd sdlwidgets; $(MAKE) clean
++ cd src; $(MAKE) clean
+ cd doc; rm -rf html
+ unison:
+- cd src; make unison
++ cd src; $(MAKE) unison
+ gunison:
+- cd src; make gunison
++ cd src; $(MAKE) gunison
+ snapshot-src:
+ ln -s . wop; \
+ tar cjvf wop-`date +%F`.tar.bz2 \
+--- src/Makefile.orig 2006-02-13 10:14:01.000000000 +0100
++++ src/Makefile 2007-04-27 18:36:22.000000000 +0200
+@@ -18,7 +18,7 @@
+ -DUSE_SDL -DNEW=new\(std::nothrow\) \
+ -I../sdlwidgets \
+ $(shell sdl-config --cflags) # -g
+-LDFLAGS = -L../sdlwidgets -lsdlwidgets -lz \
++LIBS = -L../sdlwidgets -lsdlwidgets -lz \
+ -lm -lSDL_net -lSDL_mixer -lSDL_ttf -lSDL_image \
+ $(shell sdl-config --libs) # -g
+
+@@ -56,7 +56,7 @@
+
+ $(TARGET): $(OBJECT_FILES) Makefile ../sdlwidgets/libsdlwidgets.a
+ -mkdir ../bin
+- $(CXX) $(OBJECT_FILES) -o $(TARGET) $(LDFLAGS)
++ $(CXX) $(LDFLAGS) $(OBJECT_FILES) -o $(TARGET) $(LIBS)
+
+ %.o: %.cpp Makefile
+ $(CXX) $(CXXFLAGS) -c $< -o $@ \ No newline at end of file
diff --git a/games-arcade/wop/files/wop-0.4.3-gcc43.patch b/games-arcade/wop/files/wop-0.4.3-gcc43.patch
new file mode 100644
index 000000000000..903a97ba92ce
--- /dev/null
+++ b/games-arcade/wop/files/wop-0.4.3-gcc43.patch
@@ -0,0 +1,32 @@
+--- src/scusibot.cpp.old 2010-01-05 15:41:23.000000000 +0100
++++ src/scusibot.cpp 2010-01-05 15:41:46.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include "stationarygun.hpp"
+ #include "global.hpp"
+ #include <vector>
++#include <algorithm>
+
+ ScusiBot::ScusiBot()
+ : m_event( Event::EMPTY ), m_count( 0 ), m_state( IDLE ) {
+--- src/gameinfowindow.cpp.old 2010-01-05 15:45:09.000000000 +0100
++++ src/gameinfowindow.cpp 2010-01-05 15:46:08.000000000 +0100
+@@ -10,6 +10,8 @@
+ #include "avatarworm.hpp"
+ #include "wopsprites.hpp"
+ #include "wopsprites.cpp"
++#include "spriteset.cpp"
++#include "spritesequence.cpp"
+ #include "scorekeeper.hpp"
+ #include "wopgui.hpp"
+
+--- src/map.cpp.old 2010-01-05 15:46:35.000000000 +0100
++++ src/map.cpp 2010-01-05 15:47:06.000000000 +0100
+@@ -9,6 +9,8 @@
+ #include "world.hpp"
+ #include "wopsettings.hpp"
+ #include "objectpaths.hpp"
++#include "spriteset.cpp"
++#include "spritesequence.cpp"
+
+ /**********************************************************/
+
diff --git a/games-arcade/wop/metadata.xml b/games-arcade/wop/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/wop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/wop/wop-0.4.3-r1.ebuild b/games-arcade/wop/wop-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..c8edd635a714
--- /dev/null
+++ b/games-arcade/wop/wop-0.4.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit eutils toolchain-funcs games
+
+MY_DATA_V="2005-12-21"
+MY_DATA_P="${PN}data-${MY_DATA_V}"
+DESCRIPTION="Worms of Prey - A multi-player, real-time clone of Worms"
+HOMEPAGE="http://wormsofprey.org/"
+SRC_URI="http://wormsofprey.org/download/${P}-src.tar.bz2
+ http://wormsofprey.org/download/${MY_DATA_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ x11-misc/makedepend"
+
+MY_DATA_S=${WORKDIR}/${MY_DATA_P}
+
+src_prepare() {
+ # correct path to global woprc
+ sed -i \
+ -e "s:/etc/woprc:${GAMES_SYSCONFDIR}/woprc:g" \
+ src/wopsettings.cpp \
+ || die "sed failed"
+ # patch global woprc with the correct data files location and install it
+ sed -i \
+ -e "s:^data =.*$:data = ${GAMES_DATADIR}/${PN}:" \
+ woprc \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX)
+}
+
+src_install() {
+ dogamesbin bin/${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${MY_DATA_S}"/*
+ insinto "${GAMES_SYSCONFDIR}"
+ doins woprc
+ newicon "${MY_DATA_S}"/images/misc/icons/wop16.png ${PN}.png
+ make_desktop_entry wop "Worms of Prey"
+ dodoc AUTHORS ChangeLog README{,-Libraries.txt} REVIEWS
+ prepgamesdirs
+}