summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-22 17:43:53 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-22 17:43:53 +0100
commit1073cfb79d527a47ad80625bfd1460e438da6685 (patch)
tree320c875d4badf1a7b80da26e205fab1a9fbec499 /games-arcade/xrick/files
parentgames-util/etswitch: Port to EAPI 7 (diff)
downloadgentoo-1073cfb79d527a47ad80625bfd1460e438da6685.tar.gz
gentoo-1073cfb79d527a47ad80625bfd1460e438da6685.tar.bz2
gentoo-1073cfb79d527a47ad80625bfd1460e438da6685.zip
games-arcade/xrick: Port to EAPI 7
Closes: https://bugs.gentoo.org/707136 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade/xrick/files')
-rw-r--r--games-arcade/xrick/files/xrick-021212-Makefile.patch30
-rw-r--r--games-arcade/xrick/files/xrick-021212-fno-common.patch34
2 files changed, 64 insertions, 0 deletions
diff --git a/games-arcade/xrick/files/xrick-021212-Makefile.patch b/games-arcade/xrick/files/xrick-021212-Makefile.patch
new file mode 100644
index 000000000000..2911f4715d45
--- /dev/null
+++ b/games-arcade/xrick/files/xrick-021212-Makefile.patch
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -71,10 +71,8 @@
+ all:
+ @echo "ROOTDIR=$(ROOTDIR)" > Makefile.global
+ @echo "XOBJ=$(XOBJ)" >> Makefile.global
+- @echo "CFLAGS=-g -ansi -pedantic -Wall -W -O2 -I $(ROOTDIR)/include $(shell sdl-config --cflags)" >> Makefile.global
+- @echo "LDFLAGS=-lz $(shell sdl-config --libs)" >> Makefile.global
+- @echo "CC=gcc" >> Makefile.global
+- @echo "CPP=gcc -E" >> Makefile.global
++ @echo "CFLAGS+=-pedantic -Wall -I$(ROOTDIR)/include $(shell sdl-config --cflags)" >> Makefile.global
++ @echo "LIBS+=-lz $(shell sdl-config --libs)" >> Makefile.global
+ $(MAKE) -C src all
+
+ clean:
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -40,10 +40,10 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJECTS) $(XOBJ)
+- $(CC) $(OBJECTS) $(XOBJ) $(LDFLAGS) -o $(TARGET)
++ $(CC) $(LDFLAGS) $(OBJECTS) $(XOBJ) -o $(TARGET) $(LIBS)
+
+ %.o: %.c
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ xrick.res: xrick.rc
+ windres $< -O coff -o $@
diff --git a/games-arcade/xrick/files/xrick-021212-fno-common.patch b/games-arcade/xrick/files/xrick-021212-fno-common.patch
new file mode 100644
index 000000000000..d3c05c30dbef
--- /dev/null
+++ b/games-arcade/xrick/files/xrick-021212-fno-common.patch
@@ -0,0 +1,34 @@
+--- a/include/img.h
++++ b/include/img.h
+@@ -27,7 +27,7 @@
+ U8 *pixels;
+ } img_t;
+
+-img_t *IMG_SPLASH;
++extern img_t *IMG_SPLASH;
+
+ #endif
+
+--- a/src/dat_snd.c
++++ b/src/dat_snd.c
+@@ -19,14 +19,14 @@
+
+ sound_t *WAV_WAA;
+ sound_t *WAV_BOMB;
+-sound_t *WAV_BULLET;
+-sound_t *WAV_WALK;
+-sound_t *WAV_JUMP;
++extern sound_t *WAV_BULLET;
++extern sound_t *WAV_WALK;
++extern sound_t *WAV_JUMP;
+ sound_t *WAV_TING;
+-sound_t *WAV_BOMBSHHT;
+-sound_t *WAV_BONUS;
++extern sound_t *WAV_BOMBSHHT;
++extern sound_t *WAV_BONUS;
+ sound_t *WAV_SHHT;
+-sound_t *WAV_BOX;
++extern sound_t *WAV_BOX;
+ sound_t *WAV_DDDING;
+
+ #endif /* ENABLE_SOUND */