summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/xrick/xrick-021212-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/xrick/xrick-021212-r1.ebuild')
-rw-r--r--games-arcade/xrick/xrick-021212-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-arcade/xrick/xrick-021212-r1.ebuild b/games-arcade/xrick/xrick-021212-r1.ebuild
new file mode 100644
index 000000000000..4522774011b9
--- /dev/null
+++ b/games-arcade/xrick/xrick-021212-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Clone of the Rick Dangerous adventure game from the 80's"
+HOMEPAGE="http://www.bigorno.net/xrick/"
+SRC_URI="http://www.bigorno.net/xrick/${P}.tgz"
+
+LICENSE="GPL-1+ xrick"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+RESTRICT="mirror bindist" # bug #149097
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./xrick.6.gz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}*.patch
+ sed -i \
+ -e "/^run from/d" \
+ -e "/data.zip/ s:the directory where xrick is:$(games_get_libdir)/${PN}.:" \
+ xrick.6 || die
+
+ sed -i \
+ -e "s:data.zip:$(games_get_libdir)/${PN}/data.zip:" \
+ src/xrick.c || die
+
+ sed -i \
+ -e "s/-g -ansi -pedantic -Wall -W -O2/${CFLAGS}/" \
+ -e '/LDFLAGS/s/=/+=/' \
+ -e '/CC=/d' \
+ -e "/CPP=/ { s/gcc/\$(CC)/; s/\"/'/g }" \
+ Makefile || die
+}
+
+src_install() {
+ dogamesbin xrick
+ insinto "$(games_get_libdir)"/${PN}
+ doins data.zip
+ newicon src/xrickST.ico ${PN}.ico
+ make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico
+ dodoc README KeyCodes
+ doman xrick.6
+ prepgamesdirs
+}