summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 05:29:59 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:32:47 +0000
commit0bbb2095f42a698fd08cf3b5291cabc97252f5d7 (patch)
tree23d929291a2914a0cd4f000b1c9a6e13caaaeace /games-arcade
parentgames-fps/quake1-killer: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-0bbb2095f42a698fd08cf3b5291cabc97252f5d7.tar.gz
gentoo-0bbb2095f42a698fd08cf3b5291cabc97252f5d7.tar.bz2
gentoo-0bbb2095f42a698fd08cf3b5291cabc97252f5d7.zip
games-arcade/dynamitejack: port to EAPI 7, games.eclass-- (needs runtime check)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/dynamitejack/dynamitejack-1.0.23-r2.ebuild (renamed from games-arcade/dynamitejack/dynamitejack-1.0.23-r1.ebuild)17
1 files changed, 8 insertions, 9 deletions
diff --git a/games-arcade/dynamitejack/dynamitejack-1.0.23-r1.ebuild b/games-arcade/dynamitejack/dynamitejack-1.0.23-r2.ebuild
index 9929eac3aad0..90542affce2a 100644
--- a/games-arcade/dynamitejack/dynamitejack-1.0.23-r1.ebuild
+++ b/games-arcade/dynamitejack/dynamitejack-1.0.23-r2.ebuild
@@ -1,22 +1,24 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# TODO: icon
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit desktop wrapper
DESCRIPTION="A stealth game with bombs in glorious 2D"
HOMEPAGE="http://www.galcon.com/dynamitejack/"
SRC_URI="${P}.tgz"
+S="${WORKDIR}"/${PN}
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
+
RESTRICT="bindist fetch splitdebug"
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+MYGAMEDIR=/opt/${PN}
QA_PREBUILT="${MYGAMEDIR#/}/bin/*"
# linked to pulseaudio
@@ -40,8 +42,6 @@ RDEPEND="
>=x11-libs/libXi-1.7.2[abi_x86_32(-)]
>=x11-libs/libXtst-1.2.1-r1[abi_x86_32(-)]"
-S=${WORKDIR}/${PN}
-
pkg_nofetch() {
einfo "Please buy & download ${SRC_URI} from:"
einfo " ${HOMEPAGE}"
@@ -59,9 +59,8 @@ src_install() {
insinto "${MYGAMEDIR}"
doins -r *
- games_make_wrapper ${PN} "./main" "${MYGAMEDIR}/bin"
+ make_wrapper ${PN} "./main" "${MYGAMEDIR}/bin"
make_desktop_entry ${PN}
fperms +x "${MYGAMEDIR}"/bin/main
- prepgamesdirs
}