summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-16 22:05:58 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-16 22:26:36 +0200
commit13a19fdab9fab0e640ae52317482a49205715a43 (patch)
treecb583bcf9f99930f09544ba7bac613aa961b91e2 /games-arcade
parentgames-arcade/gav: Drop old (diff)
downloadgentoo-13a19fdab9fab0e640ae52317482a49205715a43.tar.gz
gentoo-13a19fdab9fab0e640ae52317482a49205715a43.tar.bz2
gentoo-13a19fdab9fab0e640ae52317482a49205715a43.zip
games-arcade/gish-demo: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gish-demo/gish-demo-1.6-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-arcade/gish-demo/gish-demo-1.6-r1.ebuild b/games-arcade/gish-demo/gish-demo-1.6-r1.ebuild
new file mode 100644
index 000000000000..1116e16d52ec
--- /dev/null
+++ b/games-arcade/gish-demo/gish-demo-1.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Play as an amorphous ball of tar that rolls and squishes around"
+HOMEPAGE="http://www.chroniclogic.com/gish.htm"
+SRC_URI="http://www.chroniclogic.com/demos/gishdemo.tar.gz -> ${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+QA_PREBUILT="${GAMES_PREFIX_OPT:1}/${PN}/gish"
+
+RDEPEND="
+ media-libs/libsdl
+ media-libs/libvorbis
+ virtual/opengl
+ x11-libs/libX11
+ >=media-libs/openal-1.6.372
+"
+DEPEND=""
+
+S="${WORKDIR}/gishdemo"
+
+src_install() {
+ local dir=/opt/${PN}
+ local gishbin=gishdemo
+ use amd64 && gishbin=gishdemo_64
+
+ insinto "${dir}"
+ doins -r *
+ fperms +x "${dir}"/${gishbin}
+ make_wrapper gish ./${gishbin} "${dir}"
+
+ einstalldocs
+}