summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-17 22:20:46 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-17 23:00:41 +0200
commit3bf39a693a13b5550cd44d0d2bb279165b568eec (patch)
treee326c5b731cd1556e66fb6bfd23a935151fb38f0 /games-arcade
parentdev-libs/openssl: Rev bump to add patch for CVE-2018-0737 (diff)
downloadgentoo-3bf39a693a13b5550cd44d0d2bb279165b568eec.tar.gz
gentoo-3bf39a693a13b5550cd44d0d2bb279165b568eec.tar.bz2
gentoo-3bf39a693a13b5550cd44d0d2bb279165b568eec.zip
games-arcade/holotz-castle: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch8
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch4
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch4
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild52
4 files changed, 60 insertions, 8 deletions
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
index bb834656601d..cdf814546e1d 100644
--- a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
@@ -1,5 +1,5 @@
---- JLib/Makefile
-+++ JLib/Makefile
+--- a/JLib/Makefile
++++ b/JLib/Makefile
@@ -19,7 +19,7 @@
endif
@@ -29,8 +29,8 @@
.PHONY: install
install:
---- src/Makefile
-+++ src/Makefile
+--- a/src/Makefile
++++ b/src/Makefile
@@ -30,7 +30,7 @@
DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
index 0c3af53591bf..ecf9d5c32de9 100644
--- a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
@@ -1,5 +1,5 @@
---- JLib/JLib/Util/JFS.cpp
-+++ JLib/JLib/Util/JFS.cpp
+--- a/JLib/JLib/Util/JFS.cpp
++++ b/JLib/JLib/Util/JFS.cpp
@@ -887,7 +887,7 @@
// Si es un directorio lo importa recursivamente
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch
index 2e23b2a40995..efcf379fb129 100644
--- a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch
@@ -1,5 +1,5 @@
---- src/Makefile.old 2011-06-22 06:09:53.195025702 +0200
-+++ src/Makefile 2011-06-22 06:10:54.774927134 +0200
+--- a/src/Makefile.old 2011-06-22 06:09:53.195025702 +0200
++++ b/src/Makefile 2011-06-22 06:10:54.774927134 +0200
@@ -43,7 +43,7 @@
# Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo tambiƩn en el Makefile de JLib.
# Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
new file mode 100644
index 000000000000..16ed5d364bad
--- /dev/null
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop toolchain-funcs
+
+DESCRIPTION="2D platform game"
+HOMEPAGE="http://www.mainreactor.net/holotzcastle/en/index_en.html"
+SRC_URI="http://www.mainreactor.net/holotzcastle/download/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/opengl
+ virtual/glu
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-underlink.patch
+)
+
+src_compile() {
+ tc-export AR
+ emake -C JLib
+ emake -C src HC_BASE=/usr/share/${PN}/
+}
+
+src_install() {
+ dobin holotz-castle holotz-castle-editor
+ insinto /usr/share/${PN}/game
+ doins -r res/*
+ insinto /usr/share/${PN}/editor
+ doins -r HCedHome/res/*
+ newicon res/icon/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Holotz's Castle" /usr/share/pixmaps/${PN}.bmp
+ make_desktop_entry ${PN}-editor "Holotz's Castle - Editor" \
+ /usr/share/pixmaps/${PN}.bmp
+ dodoc doc/MANUAL*.txt
+ doman man/*.6
+}