summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-17 23:51:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-18 00:20:46 -0400
commit3c503cc09585fe79216a773176d9fe25e87e6dd7 (patch)
tree384d04895a7dd8b9b6b20127424deed55308ab65 /games-arcade
parentgames-arcade/apricots: add github remote-id (diff)
downloadgentoo-3c503cc09585fe79216a773176d9fe25e87e6dd7.tar.gz
gentoo-3c503cc09585fe79216a773176d9fe25e87e6dd7.tar.bz2
gentoo-3c503cc09585fe79216a773176d9fe25e87e6dd7.zip
games-arcade/apricots: add 0.2.7 (new upstream)
Now using SDL2, and new ebuild. Closes: https://bugs.gentoo.org/626524 Closes: https://bugs.gentoo.org/679038 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/apricots/Manifest2
-rw-r--r--games-arcade/apricots/apricots-0.2.7.ebuild40
-rw-r--r--games-arcade/apricots/files/apricots-0.2.7-sign-undef.patch10
3 files changed, 52 insertions, 0 deletions
diff --git a/games-arcade/apricots/Manifest b/games-arcade/apricots/Manifest
index aca5a7158470..b2b36ece9277 100644
--- a/games-arcade/apricots/Manifest
+++ b/games-arcade/apricots/Manifest
@@ -1 +1,3 @@
DIST apricots-0.2.6.tar.gz 768568 BLAKE2B 82fa6d4be5f1a9ed86e968a4645822cbf558ea37df956d54d0f07e3260ca2e7ff561ae6ea357dabb2c35b7bfd4ff0d806dda5cf51cbb3a956ebdba52f6ef526a SHA512 cf8a988d316382469e4b13a86315c760b702b3d490398cf2fe96f119ba743c1ff707c09228dbbf4eb601189fece708913a621b04c44e9d93162639ccbd502cf5
+DIST apricots-0.2.7.tar.gz 388024 BLAKE2B 5d16cb2637580ae728aa4f1b3911801effa6c79faabf7f3a1c026de8d91aaa582c8063ae33152c44fc9878ae0f7126fdb6ab0363b562e90c7359bcfe6ac78391 SHA512 7f97759402703962f660cdf609f50bb9a4465cc727d3fd17751eb5863b0b9131d9014eab50632c1638130f7e4223c89c45c12cecbc9fe2639943def2ce80ae25
+DIST apricots.png 1965 BLAKE2B 164e06ec9856273077636b347cac555cc49f5f38faffeea6f43b9032edee9dfebedce24470f70b185707ee2e467d861164a9c90c370ada5ff89d5c4854b99e7c SHA512 5d637707d7cfa775e5f3d3416a51abbbb39369cf0bfd9be871295ca3079530c25b893076c2cb6a6621586d67860920e079cb4f491d2c67ff13ce80e56a2cf4e5
diff --git a/games-arcade/apricots/apricots-0.2.7.ebuild b/games-arcade/apricots/apricots-0.2.7.ebuild
new file mode 100644
index 000000000000..b7c7ed818813
--- /dev/null
+++ b/games-arcade/apricots/apricots-0.2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Fly a plane around and bomb/shoot the enemy (port of Planegame from Amiga)"
+HOMEPAGE="https://github.com/moggers87/apricots"
+SRC_URI="
+ https://github.com/moggers87/apricots/releases/download/v${PV}/${P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test" # this is only static analysis / linter tests
+
+RDEPEND="
+ media-libs/freealut
+ media-libs/libsdl2[sound,video]
+ media-libs/openal"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sign-undef.patch
+)
+
+src_install() {
+ emake DESTDIR="${D}" datadir="${ED}/usr/share" install
+ einstalldocs
+
+ insinto /etc
+ doins ${PN}/${PN}.cfg
+ rm "${ED}"/usr/share/${PN}/apricots.cfg
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} ${PN^}
+}
diff --git a/games-arcade/apricots/files/apricots-0.2.7-sign-undef.patch b/games-arcade/apricots/files/apricots-0.2.7-sign-undef.patch
new file mode 100644
index 000000000000..c1904ea9f8be
--- /dev/null
+++ b/games-arcade/apricots/files/apricots-0.2.7-sign-undef.patch
@@ -0,0 +1,10 @@
+Undefined reference to sign() when using -O1 or above.
+--- a/apricots/all.cpp
++++ b/apricots/all.cpp
+@@ -19,5 +19,5 @@
+ // Sign function
+
+-inline int sign(int n) { return (0 < n) - (n < 0); }
++int sign(int n) { return (0 < n) - (n < 0); }
+
+ // Error message for switch statements that shouldn't ever get to default