summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-16 16:32:16 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-16 16:32:16 +0200
commit727bfae309dc7696c314a86c5d478af8b136391e (patch)
tree71d056907680951d210549c3356e3799a982d3d4 /games-arcade
parentmedia-tv/kodi: 18.2_rc1 version bump (diff)
downloadgentoo-727bfae309dc7696c314a86c5d478af8b136391e.tar.gz
gentoo-727bfae309dc7696c314a86c5d478af8b136391e.tar.bz2
gentoo-727bfae309dc7696c314a86c5d478af8b136391e.zip
games-arcade/performous: Fix building against boost 1.70
Closes: https://bugs.gentoo.org/671594 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/performous/files/performous-1.1-boost-1.70.patch52
-rw-r--r--games-arcade/performous/performous-1.1-r1.ebuild1
2 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/performous/files/performous-1.1-boost-1.70.patch b/games-arcade/performous/files/performous-1.1-boost-1.70.patch
new file mode 100644
index 000000000000..d868e1279659
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.1-boost-1.70.patch
@@ -0,0 +1,52 @@
+https://bugs.gentoo.org/671594
+
+--- a/game/audio.cc
++++ b/game/audio.cc
+@@ -77,7 +77,7 @@
+ static ptime getTime() { return microsec_clock::universal_time(); }
+ // Conversion helpers
+ static double getSeconds(time_duration t) { return 1e-6 * t.total_microseconds(); }
+- static time_duration getDuration(double seconds) { return microseconds(1e6 * seconds); }
++ static time_duration getDuration(double seconds) { return microseconds(static_cast<long long>(1e6 * seconds)); }
+
+ mutable boost::mutex m_mutex;
+ ptime m_baseTime; ///< A reference time (corresponds to m_basePos)
+@@ -149,7 +149,7 @@
+ int64_t m_pos; ///< Current sample position
+ bool m_preview;
+ AudioClock m_clock;
+- time_duration durationOf(int64_t samples) const { return microseconds(1e6 * samples / srate / 2.0); }
++ time_duration durationOf(int64_t samples) const { return microseconds(static_cast<long long>(1e6 * samples / srate / 2.0)); }
+ public:
+ bool suppressCenterChannel;
+ double fadeLevel;
+--- a/game/backgrounds.hh
++++ b/game/backgrounds.hh
+@@ -7,6 +7,7 @@
+ #include <boost/scoped_ptr.hpp>
+ #include <boost/thread/mutex.hpp>
+ #include <boost/thread/thread.hpp>
++#include <boost/noncopyable.hpp>
+ #include <vector>
+
+ /// songs class for songs screen
+--- a/game/songs.hh
++++ b/game/songs.hh
+@@ -6,6 +6,7 @@
+ #include <boost/scoped_ptr.hpp>
+ #include <boost/thread/mutex.hpp>
+ #include <boost/thread/thread.hpp>
++#include <boost/noncopyable.hpp>
+ #include <set>
+ #include <sstream>
+ #include <vector>
+--- a/game/svg.cc
++++ b/game/svg.cc
+@@ -4,6 +4,7 @@
+ #include "configuration.hh"
+ #include "../common/image.hh"
+
++#include <boost/smart_ptr/shared_ptr.hpp>
+ #include <librsvg/rsvg.h>
+ #include <iostream>
+
diff --git a/games-arcade/performous/performous-1.1-r1.ebuild b/games-arcade/performous/performous-1.1-r1.ebuild
index ed88a66edefe..f40e3e183d19 100644
--- a/games-arcade/performous/performous-1.1-r1.ebuild
+++ b/games-arcade/performous/performous-1.1-r1.ebuild
@@ -64,6 +64,7 @@ PATCHES=(
"${FILESDIR}"/${P}-linguas.patch
"${FILESDIR}"/${P}-nomancompress.patch
"${FILESDIR}"/${P}-jpeg-9c.patch
+ "${FILESDIR}"/${P}-boost-1.70.patch
)
src_prepare() {