summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-02-10 00:11:07 +0200
committerMart Raudsepp <leio@gentoo.org>2024-02-10 00:25:32 +0200
commit8fea82bbd6a3a8701806b4b3c261dd1169e11efc (patch)
tree51d32c53abce67a90411ce32643294990140bdc3 /games-arcade
parentmail-client/evolution: add 3.50.4 (diff)
downloadgentoo-8fea82bbd6a3a8701806b4b3c261dd1169e11efc.tar.gz
gentoo-8fea82bbd6a3a8701806b4b3c261dd1169e11efc.tar.bz2
gentoo-8fea82bbd6a3a8701806b4b3c261dd1169e11efc.zip
games-arcade/gnome-nibbles: add 4.0.2
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gnome-nibbles/Manifest1
-rw-r--r--games-arcade/gnome-nibbles/gnome-nibbles-4.0.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/gnome-nibbles/Manifest b/games-arcade/gnome-nibbles/Manifest
index 180ce5ccdaa5..4c6c23228323 100644
--- a/games-arcade/gnome-nibbles/Manifest
+++ b/games-arcade/gnome-nibbles/Manifest
@@ -1,2 +1,3 @@
DIST gnome-nibbles-3.38.3.tar.xz 388996 BLAKE2B cb8482568e5a9e87d2ff974ab9c1a7a33d353554a3bf56774dd451da06cfe97267ae82c90d8331563886c1051e0d59693785773b31247c450c795c05e748854c SHA512 08102ab6a48cc121b2ea4d0edc32e3ee7b0eb56441d061367ca7c058cf94046fe185767999b262c9aaeac70e2086333f024b70ba85810e4275a9cbdede5dacee
DIST gnome-nibbles-4.0.1.tar.xz 417716 BLAKE2B 18703fb353097c75b0a36caaca60ae2d2a2186920cfe5d8bcb67d594608beee29de46f70557ff37e0edd819e6838acfc98250c568605e2f657627c60ea56ae5f SHA512 802bf7f320613b3a1d57cbe7ab804ba07781ad3c5e6ea3e5d1d2ee0d744055265b05895987d84714ca6eeb7eca832f138a2427f5c00d25ef14c8ef8976ddae2f
+DIST gnome-nibbles-4.0.2.tar.xz 418992 BLAKE2B d94e0c11c683765ff50ec4c72669b6ccdac405a107d1f68675b95ae386ff3ae825e0783ce45f26e974675a243d98a00bb1be224ae29e5f25e3735cf1bbf25990 SHA512 a0f82e4860cc05f9b2fdd2037a59088ef1747e17f660778ba68d6eed328b962e27606dfe2e7a9b0a8f46c68bb5f6ff26f7048fae24ab17fe8d63685656e85025
diff --git a/games-arcade/gnome-nibbles/gnome-nibbles-4.0.2.ebuild b/games-arcade/gnome-nibbles/gnome-nibbles-4.0.2.ebuild
new file mode 100644
index 000000000000..fa838bb0042b
--- /dev/null
+++ b/games-arcade/gnome-nibbles/gnome-nibbles-4.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Nibbles clone for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nibbles https://gitlab.gnome.org/GNOME/gnome-nibbles"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.78.0:2
+ dev-libs/libgee:0.8=
+ >=media-libs/gsound-1.0.2
+ >=gui-libs/gtk-4.6:4
+ x11-libs/pango
+ >=dev-libs/libgnome-games-support-2.0.0:2=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}