summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 20:40:05 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:26:19 +0200
commita85d61595417253e7bdee8050241fe902a531937 (patch)
treeafb90f22bc49402bf41b3f9ef1c042ae9d1ed803 /games-arcade
parentgames-arcade/supertransball2: Drop old (diff)
downloadgentoo-a85d61595417253e7bdee8050241fe902a531937.tar.gz
gentoo-a85d61595417253e7bdee8050241fe902a531937.tar.bz2
gentoo-a85d61595417253e7bdee8050241fe902a531937.zip
games-arcade/supertransball2: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/supertransball2/Manifest2
-rw-r--r--games-arcade/supertransball2/supertransball2-1.5-r1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/games-arcade/supertransball2/Manifest b/games-arcade/supertransball2/Manifest
new file mode 100644
index 000000000000..6d026722ef4b
--- /dev/null
+++ b/games-arcade/supertransball2/Manifest
@@ -0,0 +1,2 @@
+DIST stransball2-v15-linux.zip 302212 BLAKE2B 8b45e32f37c805e75ba0d19ef004d75baea689fe87e946d50301cef01230492fd531b4100bc6200a261c24463443b2811faea8d200d15b15af0c884dbc285d2a SHA512 e87655dfca039c0c8553372b4da139f1d8fa420aad1909b422318dc049a9f7972c8d2398b83fde677b3eaf21d2d70fad73d7ec0c4b7bcbeacbf3544e6e575f6a
+DIST supertransball2_1.5-8.debian.tar.xz 26148 BLAKE2B 50ada1b6976da9686aa5cabd5e3a04222e30f9c69565018eebe51271842842dab88829c0672d7375995e3835c3be4983c8990e736278177d7d10596ed2453a0c SHA512 efbb8517b73d4413755663f96aa01eb679b43876091920a6d9a9fc0a31d001828aa536ac59e74172fa519d14b1dff117c150c022fb8f3898efbee2901a418a53
diff --git a/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild b/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild
new file mode 100644
index 000000000000..96768ec7e1cd
--- /dev/null
+++ b/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit epatch desktop versionator
+
+MY_PV="$(delete_all_version_separators)"
+MY_P="stransball2-v${MY_PV}"
+FILE="${MY_P}-linux"
+
+DESCRIPTION="Thrust clone"
+HOMEPAGE="http://www.braingames.getput.com/stransball2/"
+SRC_URI="http://braingames.bugreport.nl/stransball2/${FILE}.zip
+ mirror://debian/pool/main/s/${PN}/${PN}_${PV}-8.debian.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ media-libs/sge
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}/${P}/sources"
+
+src_unpack() {
+ unpack ${A}
+ mv -f "${FILE}" ${P}
+}
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:/usr/share/games:/usr/share:" \
+ "${WORKDIR}"/debian/patches/0001-Fix-unix-paths-and-Makefile.patch || die
+
+ epatch "${WORKDIR}"/debian/patches/*.patch
+
+ sed -i \
+ -e "s: -I/usr/local/include/SDL::" \
+ -e "s:-g3 -O3:\$(CXXFLAGS):" \
+ -e "s:c++:\$(CXX):" \
+ Makefile || die "sed Makefile failed"
+}
+
+src_install() {
+ cd ..
+ dobin ${PN}
+
+ doicon ../debian/${PN}.png
+ make_desktop_entry ${PN} "Super Transball 2"
+ dodoc readme.txt
+ doman ../debian/supertransball2.6
+
+ insinto "/usr/share/${PN}"
+ doins -r demos graphics maps sound
+}