summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-16 21:40:01 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-16 22:26:21 +0200
commitd0c0ffb7c1064265297be5cd2541253550c0b141 (patch)
tree5ae3a3d8844d54cc601342dc8b3113c47011873f /games-arcade
parentmail-client/mutt: version bump to 1.9.5 (diff)
downloadgentoo-d0c0ffb7c1064265297be5cd2541253550c0b141.tar.gz
gentoo-d0c0ffb7c1064265297be5cd2541253550c0b141.tar.bz2
gentoo-d0c0ffb7c1064265297be5cd2541253550c0b141.zip
games-arcade/excido: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/excido/excido-0.1.5c-r3.ebuild40
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-build.patch4
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-freealut.patch4
3 files changed, 44 insertions, 4 deletions
diff --git a/games-arcade/excido/excido-0.1.5c-r3.ebuild b/games-arcade/excido/excido-0.1.5c-r3.ebuild
new file mode 100644
index 000000000000..cea4558b0b61
--- /dev/null
+++ b/games-arcade/excido/excido-0.1.5c-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A fast paced action game"
+HOMEPAGE="http://icculus.org/excido/"
+SRC_URI="http://icculus.org/excido/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/physfs
+ media-libs/libsdl[opengl]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ media-libs/openal
+ media-libs/freealut"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-freealut.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_compile() {
+ emake DATADIR=/usr/share/${PN}/
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins data/*
+ dodoc BUGS CHANGELOG HACKING README TODO \
+ keyguide.txt data/CREDITS data/*.txt
+}
diff --git a/games-arcade/excido/files/excido-0.1.5c-build.patch b/games-arcade/excido/files/excido-0.1.5c-build.patch
index 779d9c3f4066..1735b51ccdfc 100644
--- a/games-arcade/excido/files/excido-0.1.5c-build.patch
+++ b/games-arcade/excido/files/excido-0.1.5c-build.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -1,8 +1,8 @@
-CC=g++
-CFLAGS=`sdl-config --cflags` #-g -Wall #-O2
diff --git a/games-arcade/excido/files/excido-0.1.5c-freealut.patch b/games-arcade/excido/files/excido-0.1.5c-freealut.patch
index d0538083af1f..c29999fae25d 100644
--- a/games-arcade/excido/files/excido-0.1.5c-freealut.patch
+++ b/games-arcade/excido/files/excido-0.1.5c-freealut.patch
@@ -1,5 +1,5 @@
---- src/SoundCore.cpp
-+++ src/SoundCore.cpp
+--- a/src/SoundCore.cpp
++++ b/src/SoundCore.cpp
@@ -352,32 +352,13 @@
PHYSFS_close(filehandle);