summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-06-09 19:11:17 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-06-15 16:00:18 -0400
commitd55af2849c4530548a758a344f60aed2d098238a (patch)
tree3d56df61eec12bb454b70be9e3fe572b5dedb1d4 /games-board/atakks
parentgames-arcade/notpacman: EAPI bump, update eclass usage (diff)
downloadgentoo-d55af2849c4530548a758a344f60aed2d098238a.tar.gz
gentoo-d55af2849c4530548a758a344f60aed2d098238a.tar.bz2
gentoo-d55af2849c4530548a758a344f60aed2d098238a.zip
games-board/atakks: EAPI bump, minor improvements
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board/atakks')
-rw-r--r--games-board/atakks/atakks-1.0-r1.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/games-board/atakks/atakks-1.0-r1.ebuild b/games-board/atakks/atakks-1.0-r1.ebuild
index 052924ba8c88..c714c0d43dc3 100644
--- a/games-board/atakks/atakks-1.0-r1.ebuild
+++ b/games-board/atakks/atakks-1.0-r1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
-MY_P=${P/-/_}
-DESCRIPTION="A clone of Ataxx"
+inherit desktop toolchain-funcs
+
+MY_P="${P/-/_}"
+DESCRIPTION="Clone of Ataxx"
HOMEPAGE="http://team.gcu-squad.org/~fab"
# no version upstream
#SRC_URI="http://team.gcu-squad.org/~fab/down/${PN}.tgz"
@@ -14,12 +15,11 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libsdl:0"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PV}-warnings.patch
@@ -36,6 +36,7 @@ src_prepare() {
}
src_compile() {
+ tc-export CC
emake E_CFLAGS="${CFLAGS}"
}