summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-08 16:33:26 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-14 12:26:33 -0500
commit68aebe07dc2fd628086918fa6e9b7adf880f3238 (patch)
treec28d4cf5a69d9ab7483e002637eca7eebde1656e /games-board/camato
parentnet-irc/quassel: remove old (diff)
downloadgentoo-68aebe07dc2fd628086918fa6e9b7adf880f3238.tar.gz
gentoo-68aebe07dc2fd628086918fa6e9b7adf880f3238.tar.bz2
gentoo-68aebe07dc2fd628086918fa6e9b7adf880f3238.zip
games-board/camato: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/camato')
-rw-r--r--games-board/camato/camato-0.7.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-board/camato/camato-0.7.4-r1.ebuild b/games-board/camato/camato-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..30daaa38821b
--- /dev/null
+++ b/games-board/camato/camato-0.7.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit versionator
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="A map editor for the game gnocatan"
+HOMEPAGE="http://yusei.ragondux.com/loisirs_jdp_catane_camato-en.html"
+SRC_URI="http://yusei.ragondux.com/files/gnocatan/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-ruby/ruby-gtk2"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ default
+
+ rm -f Makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r *.rb img
+ dodoc ChangeLog README
+}