summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-03-13 22:44:04 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-03-13 22:44:34 +0000
commit4c06333a40da1166407b071e2eebc712b2663c3d (patch)
tree180bb81526c59a25e57c9f2bcbbf68f18da6a753 /games-board/cockatrice/files
parentgames-board/cockatrice: Version bump to 20190304, drop 20181220 (diff)
downloadgentoo-4c06333a40da1166407b071e2eebc712b2663c3d.tar.gz
gentoo-4c06333a40da1166407b071e2eebc712b2663c3d.tar.bz2
gentoo-4c06333a40da1166407b071e2eebc712b2663c3d.zip
games-board/cockatrice: Disable automagic use of ccache with a patch
This has been submitted upstream. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-board/cockatrice/files')
-rw-r--r--games-board/cockatrice/files/use-ccache.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-board/cockatrice/files/use-ccache.patch b/games-board/cockatrice/files/use-ccache.patch
new file mode 100644
index 000000000000..16deeaf0bb73
--- /dev/null
+++ b/games-board/cockatrice/files/use-ccache.patch
@@ -0,0 +1,33 @@
+From 494501bbc88d30d9f1ceb6fb3fbd428eeb58ddee Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Wed, 13 Mar 2019 22:18:45 +0000
+Subject: [PATCH] Add USE_CCACHE option to CMake so that ccache can be forcibly
+ disabled
+
+---
+ CMakeLists.txt | 15 +++++++++------
+ 1 file changed, 9 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cc39e77..59eec3d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,12 +25,15 @@ ELSE()
+ ENDIF()
+
+ # Early detect ccache
++OPTION(USE_CCACHE "Cache the build results with ccache" ON)
++if(USE_CCACHE)
+ find_program(CCACHE_PROGRAM ccache)
+ if(CCACHE_PROGRAM)
+ # Support Unix Makefiles and Ninja
+ set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_PROGRAM}")
+ MESSAGE(STATUS "Found CCache ${CCACHE_PROGRAM}")
+ endif()
++endif()
+
+ # A project name is needed for CPack
+ # Version can be overriden by git tags, see cmake/getversion.cmake
+--
+2.20.1
+