summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-22 17:07:15 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-22 17:21:30 +0200
commita29075794f091cb797a77a9f8ce0e9dff588c42c (patch)
treecafc769708abb69467b2e28987391b3227f40a84 /games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild
parentgnome-base/dconf-editor: bump to 3.34.4 (diff)
downloadgentoo-a29075794f091cb797a77a9f8ce0e9dff588c42c.tar.gz
gentoo-a29075794f091cb797a77a9f8ce0e9dff588c42c.tar.bz2
gentoo-a29075794f091cb797a77a9f8ce0e9dff588c42c.zip
games-board/four-in-a-row: bump to 3.34.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild')
-rw-r--r--games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild b/games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild
new file mode 100644
index 000000000000..3dd8ca7f4c4b
--- /dev/null
+++ b/games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row"
+
+# Code and most themes are GPL-3+, CC-BY-SA-3.0 is user help license in v3.32.0
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.13.2:3
+ >=gnome-base/librsvg-2.32.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+ gnome-base/librsvg[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}