summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-31 23:04:41 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-01 02:34:40 +0300
commit00ba9a6ea2754bba41483967f967c0afdae4c117 (patch)
tree70b883f95ccb29dca91d6437dcabebe0edc0b48f /games-board/gnome-chess/gnome-chess-3.28.1.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (69.0.3497.72, 70.0.3534.4) (diff)
downloadgentoo-00ba9a6ea2754bba41483967f967c0afdae4c117.tar.gz
gentoo-00ba9a6ea2754bba41483967f967c0afdae4c117.tar.bz2
gentoo-00ba9a6ea2754bba41483967f967c0afdae4c117.zip
games-board/gnome-chess: bump to 3.28.1
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'games-board/gnome-chess/gnome-chess-3.28.1.ebuild')
-rw-r--r--games-board/gnome-chess/gnome-chess-3.28.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-board/gnome-chess/gnome-chess-3.28.1.ebuild b/games-board/gnome-chess/gnome-chess-3.28.1.ebuild
new file mode 100644
index 000000000000..ddb05746bd32
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-3.28.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_MIN_API_VERSION="0.36"
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.19:3
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="For being able to play against computer you will
+need to install a chess engine like, for example, games-board/gnuchess"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}