summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/gnome-hearts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/gnome-hearts')
-rw-r--r--games-board/gnome-hearts/Manifest1
-rw-r--r--games-board/gnome-hearts/gnome-hearts-0.3.1-r1.ebuild49
-rw-r--r--games-board/gnome-hearts/metadata.xml6
3 files changed, 56 insertions, 0 deletions
diff --git a/games-board/gnome-hearts/Manifest b/games-board/gnome-hearts/Manifest
new file mode 100644
index 000000000000..822b2b35be3c
--- /dev/null
+++ b/games-board/gnome-hearts/Manifest
@@ -0,0 +1 @@
+DIST gnome-hearts-0.3.1.tar.gz 637916 SHA256 4b9477e8bb2d48a86021ae512a713fd405a96d52cf711ff549cfe0d119bf56b3 SHA512 5528c92bba80cc97ce1f51e3b2652b5d6b30c0e90e7a8f023dcdf5c3420b2d1fbab29fc3d974884d8cb351a44b8b97c05242f26b70d5e1d02d593a17452ad19f WHIRLPOOL 50259c6e2bdc56bc73cbf59d6eb0cdd37053850262dfca5c4218b9d4ca4dc512df2d6db5167323bd9084a0ddafc2bfdc9d6371210ba8656faa46847de8a8a500
diff --git a/games-board/gnome-hearts/gnome-hearts-0.3.1-r1.ebuild b/games-board/gnome-hearts/gnome-hearts-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..ca5f94415077
--- /dev/null
+++ b/games-board/gnome-hearts/gnome-hearts-0.3.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG=no
+
+PYTHON_COMPAT=( python2_7 )
+inherit gnome2 python-single-r1
+
+DESCRIPTION="A clone of classic hearts card game"
+HOMEPAGE="http://www.gnome-hearts.org"
+SRC_URI="http://www.jejik.com/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeui-2
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ dev-util/intltool
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ # make src_test work
+ echo gnome-hearts.desktop.in >> po/POTFILES.skip
+
+ sed -i \
+ -e '/No name/d' \
+ -e '/^Icon/s/.png//' \
+ -e '/^Encoding/d' \
+ gnome-hearts.desktop.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls)
+}
diff --git a/games-board/gnome-hearts/metadata.xml b/games-board/gnome-hearts/metadata.xml
new file mode 100644
index 000000000000..3057a54e98e6
--- /dev/null
+++ b/games-board/gnome-hearts/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<herd>games</herd>
+</pkgmetadata>